Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Must Click To Play Flash, even though Click to Play is supposed to be off...

  • hi everyone 🙂

    opera is showing me a gray panel that says i need to click to run adobe flash content,

    but in my settings, i have it set to "run all plug in content" there another setting i'm not aware of, that is causing me to have to manually click to run, and if so, can someone, please, guide me how to allow it?

    thank you very much 🙂

  • Disable VPN/Turbo or add the site as an exception.

  • hi there 🙂 thank you for replying 🙂 can i add the site as an exception, as you suggest? (i have old, old windows vista, with opera 36.0.2130.80)

    ...thanks!!! 🙂

  • If you have generally set Flash as "Click to play" you can add an exception in Settings > Websites > Flash, but if you use Turbo or the VPN then all Flash will be "Click to play" regardless of settings.

  • hello and thank you for replying 🙂

    ...would the "flash" section you mention, appear only IF i have enabled click to play?

    i wanted to learn how to add an exception, for the future, but when checking i don't see "flash" mentioned under settings > browser ...but maybe it's because i don't yet have click to play enabled...

    thank you 🙂

    (update it turns out i did have turbo enabled, and i disabled it and now FLASH WORKS!!! 🙂 THANKS, LEOCG!!! :))

  • Just to add, there's no built-in VPN in Opera 36, so if it is that, it must be Turbo being on.
    EDIT: Which it was!

  • Had a typo in my last post, it's Settings > Websites > Flash (post corrected now).

  • oh okay, cool! note to users of old my, old, version of opera, it refers to "plug-ins" instead of specifically mentioning flash ...and, hooray, there's a button that says "manage exceptions"!

    and yep, davehawley, there's no built in vpn in this version ...i wish there was! i hate being stuck w/ windows vista, and in turn i can't update my browsers 😞