.com being added to a word pasted into the address bar.

  • I frequently paste a word into the address bar, so Opera will search for it using Google. Recently it's been really annoying me by assuming I meant to put a .com on the end and going to some random website. Can this be turned off or is it a bug?

    Sorry for the double post, but the forum is running horrendously slow and wouldn't react to the post button.

  • Yes! I can so relate to this, brother.

  • Are you talking about auto-complementation? Maybe you can disable it in settings.

  • I have no idea what "auto-complementation" is. If you paste a word into the address bar, .com is added automatically. I never want this, I'm either looking up a word in the dictionary, or searching for information on something, or looking for a picture of it.

  • I have no idea what "auto-complementation" is

    It's a feature present in many browsers that completes a url one you type a related word in the address bar. So if you type 'opera' it will turn it into 'opera.com', if you type 'vivaldi' it will show 'vivaldi.com'.

    It should only happens if you have already visited those sites.

    If you paste a word into the address bar, .com is added automatically

    Just after you pasted/typed the word? or it happens after you 'press enter'?

    The first is automatic complementation, the second is not an Opera's feature.

    Anyway, take a look at the Privacy and security section in the settings page.

  • I just tried it with several random words, and only a few are doing it. Although the ones that I've seen it do it with in the past were sites I'd never heard of before - I can't explain that at all. Besides which, it's a very stupid idea to be adding stuff to what I type or paste without my permission. For example, if I paste (or even type) "google" into the address bar, it autocompletes it not even to google.com, but to the last thing I looked at on there - my last search. The chances of that being what I want are second to none. It should offer me this link in the dropdown box, not add it as I type so I've got to delete it.

    I've tried switching off "Use a prediction service to help complete searches and URLs typed in the address bar" in the section you suggested, and even restarted Opera and confirmed the setting stuck. But it ignored me. Typing google ina fresh tab takes me to my last search. This is exceedingly annoying and they need to fix it.

  • Bug report filed - DNAWIZ-14333

  • If I attempt to type the shortcut ‘xegbp’ for my custom search engine XE, I occasionally end up with ‘xe.comegbp’. We need a way to disable it although it is annoying enough to be considered a bug; it is capable of rendering custom search engines useless as aforementioned.

    Unticking Use a prediction service to help complete searches and URLs typed in the address bar does not resolve it. We should not have to anyway since we might still wish to use the prediction service.

  • The prediction service works fine in the drop down below where you're typing. There's no reason to place any of it into the address bar until you click it.

    I tried your example, but couldn't reproduce it. I went to xe.com to start with, so the address was loaded into it's predictor. Then I typed xegbp. The xe made .com appear, but the gbp simply wrote over it. I only experience the problem if I type nothing after what it thinks might be an address.

  • @hucker Yea, I agree completely. As for you being unable to replicate my example, I am not surprised since it rarely occurs, so I dare not say what triggers it.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.