Spell check context randomly disappears

  • Hello, im having some trouble with the spell-check on opera, i speak 3 languages so i keep having to change the spell check language depending on the website im using, the problem is that the spell check context option is often not available, but it still corrects the grammar based on currently active language.

    Really, i couldn't even change the language on this website, i had to use the search bar on ebay to change it...
    It's ridiculous...

    Here's a couple of print screens.
    https://drive.google.com/open?id=0B6r1HcTZn4RdUHZpdGxIVWNSaUk

    Is there a fix?

    Thanks

  • Really, i couldn't even change the language on this website

    You need to right click on an empty space in the text input field.

  • Doesn't even need to be empty - as long as it isn't marked as incorrect. Anywhere in an edit field that doesn't have a wavy red underline will show "Spellcheck>" on the context menu.

  • I guess you guys haven't looked at the printscreens...

  • Your second screenshot was right-clicking on a word marked as incorrect, and the Spellcheck option was missing as expected. The first screenshot was not marked as incorrect (no wavy red underline). Again as expected.

    If you want to request that Spellcheck show on both menus (a feature request), you can do that - but currently it is behaving as expected.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.