Speed Dial Blank

  • Hi,

    I recently tried to clean up all the Speed Dial entries of all computers I have been working on - guess I cleaned too much. I now have the weird behaviour, that the Speed Dial page just displays the background image, but none of the folders and bookmarks.

    I already tried deleting and re-adding all entries but without any luck.

    Is there a way to "reset" my Speed Dial?

    Cheers
    Vince

    PS: While the Speed Dial feature is really great, its management implementation is really poor. I hope that somebody will improve it in the near future ... there are many good suggestions in the forums - listen to them! Nobody wants a set of Speed Dial entries for every device he has been working on ... okay, maybe a minority. 🙂

  • While the Speed Dial feature is really great, its management implementation is really poor.

    Why do you think it's poor?

    Nobody wants a set of Speed Dial entries for every device he has been working on ... okay, maybe a minority.

    How do you know that?

    I already tried deleting and re-adding all entries but without any luck.

    Is Speed Dial enable in Start Page settings?

    When you add a entry on speed dial, it doesn't show up at all or it shows up but disappear late?

  • Regarding the implementation:

    If you sign in, you expect everything to be synchronized. Synchronization means that the same information is available on all devices. While bookmarks and passwords are synchronized, the Speed Dial is not. Instead every device creates a separate device folder. This even happens when I dual boot between Windows and Linux: Instead of recognizing the machine name and synchronizing at least the Speed Dial between those instances, I end up having two identically named folders not knowing their operating system. The perfect implementation would be to have synchronizing Speed Dials. There were discussions amongst users where some users said, that they would like to have different Speed Dials on different devices - this should be an option and not based on machine names, but user defined. The user should have one "general" oder "default" Speed Dial and could be enabled to create other Speed Dials ("mobile" for example) and assign those to their devices.

    I know that from reading dozens of user posts in forums, real life discussions with power users and academically from UX.

    The problem is, that my Speed Dial is activated and full of bookmarks, I can even add new bookmarks to the Speed Dial - but no Speed Dial entries is displayed. I just see the background image.

    Cheers
    Vince

  • If you sign in, you expect everything to be synchronized. Synchronization means that the same information is available on all devices.

    So this is how it works now.

    I know that from reading dozens of user posts in forums, real life discussions with power users and academically from UX.

    And they represent how much of the Opera users? Probably some 0,0x%.

    The problem is, that my Speed Dial is activated and full of bookmarks, I can even add new bookmarks to the Speed Dial - but no Speed Dial entries is displayed. I just see the background image.

    If you can't see the Speed Dial entries, how do you know that it has lots of them?

    Anyway, it's kinda weird. Did you try a clean standalone installation?

  • This is how it does not work. Shall I write down the steps to reproduce this unexpected behaviour? Here we go:

    • Install Opera on device 1
    • Sign in
    • Install Opera on device 2
    • Sign in
    • Add entry to Speed Dial on device 1
    • See how it does not show up on device 2
    • See two entries in "Other Speed Dials"

    From my counting it represents 98 % of the users.

    You can see the Speed Dial entries in the bookmarks: Press Ctrl + Shift + B and look for the folder "Speed Dial".

    Plain installations will work - as usual. I want to find out where Opera stores the Speed Dial entries and how deleting Foldders from "Other Speed Dials" can affect those files and them no longer being displayed properly.

  • This is how it does not work. Shall I write down the steps to reproduce this unexpected behaviour? Here we go:

    As said, this is by design. If you want it to behave in a different way then please suggest/request it on the Suggestion Box area, where for sure there are other similar requests.

  • I want to find out where Opera stores the Speed Dial entries

    In 'Bookmarks' file(s) in Opera's profile folder.

    Plain installations will work - as usual.

    If a standalone installation works then there are high chances that your profile is broken.

    how deleting Foldders from "Other Speed Dials" can affect those files and them no longer being displayed properly.

    If you delete a folder in 'other speed dials' you will remove all entries in the device that names it.

  • Do you have any insights, of what can be "broken" in those ASCII-Files?

    I can accept that a device's Speed Dial is empty after deleting the device folder.
    I cannot accept that the Speed Dial does not work after doing so.

  • The request is in the suggestion box since 2015-04. How are these suggestions rated and implemented?

  • Do you have any insights, of what can be "broken" in those ASCII-Files?

    Not exactly. Most probably 'Preferences' or 'Local State'.

    How are these suggestions rated and implemented?

    Someone from Opera would need to answer that one.

  • Update

    I did a clean install of Opera. The default Speed Dial entries are displayed. After turning on the synchronization, the Speed Dial entries are all gone. Addin a new entry to the Speed Dial shows it properly in the Bookmarks and the application icon jump list in the task bar, but not on the Speed Dial page. Opening the Speed Dial shows a short flickering and something that might be the undisplayed entry. Afterwards only the blank page with the background image is displayed. It is not an display issue, as all default entries are displayed properly as long as I do not start the synchronization. The device folder is fully operational, as I can see my Speed Dial entries on other devices.

    How can this be fixed?

  • Did this happen on going from 41.xxx to 42.xxx?

  • As far as I recall, it did not happen during a release change, but happened, when I deleted some device folders.

  • Now I also get on every new device an empty Speed Dial after signing in into my Opera account. Is there any way to get this fixed?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.