Why is text dpi different when starting from taskbar icon than from dpi-modified desktop icon?

  • Opera allows adjustment of text size via an add-on string to the start up file target, e.g., --alt-high-dpi-setting=96. That adjustment works fine when starting from the file or desktop icon, but has never taken from the taskbar icon, neither in Win 10 or earlier with Win 8/8.1 (taskbar icon pinned from desktop icon version). Anyone have an idea why? Is it the doing of Windows or Opera? Thanks,

  • Anyone have an idea why?

    Maybe because the task bar icon doesn't include that command line?

    You would need to change the registry for the command line to work no matter how Opera were launched.

  • What specifically should I be looking for and where in the registry? I assume it's a matter of finding the taskbar entries, but am not sure how they are designated or where stored.

  • What specifically should I be looking for and where in the registry?

    I don't know exactly, sorry. But try looking for 'launcher.exe'.

  • Good idea, since that narrows it a lot. My question now is does anyone know what part of the registry is the program is launched from, i.e., what part I'd need to modify with the dpi add on?

  • The taskbar shortcut should be here -
    C:\Users\Username\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar
    That's certainly the case on Windows 8.1, I guess Windows 10 is the same.
    Add the switch to the Opera run command there and that should do it.
    :)

  • Dave, Thanks, that's what I needed to find. It's turned out that by replacing the desktop icon I'd been using with launcher.exe shortcut and copying that to the tastbar, so far it's holding (and the entry you referred to shows the dpi mod). The problem now I'm running into is when I open Opera via a link in an email; it opens without the dpi change. I set Opera as the default browser, but so far that hasn't changed the behavior.

  • No problem. The shortcuts are easy to fix, but the opening of links in e-mails is harder, and has to be done by registry editing.
    You have Opera associated with htm/html files, which is part of what makes it the default browser.
    Look with registry editor at -

    HKEY_CLASSES_ROOT\.htm and HKEY_CLASSES_ROOT\.html  
    

    That should tell you what those file types are linked to.
    You will find a "command" key, which should have an "open" subkey, which contains a command line as in the shortcuts.
    If you add the switch there after "launcher.exe" that should fix the problem.
    The problem is that when Opera updates itself this may well get over-written again, so you will have to re-do the registry edit.
    It goes without saying that you should backup your registry before making any changes to it!
    :)

  • Not seeing what you're referring to under _ROOT. Not sure how to post screenshots here, so check these two for what I'm seeing. http://tinypic.com/a/b4gjub/1.

  • Find registry entries, pointing to Opera folder and ending with ".. launcher.exe %1" (there can be more options included already) and attempt to add your dpi option there. I did find some of these under HKEY_CURRENT_USER (settings for current user), probably some are under different hives (like HKEY_CLASSES_ROOT above); before changing these export existing keys to allow undo changes. I would change them one by one to find out, which affect behavior and which not. (Pointed you DefaultIcon value doesn't need to change, Shell command below of course has to be changed.)

  • Not seeing what you're referring to under _ROOT. Not sure how to post screenshots here, so check these two for what I'm seeing. http://tinypic.com/a/b4gjub/1.

    You need to look in the _ROOT section of the registry for an entry called "Opera.HTML".
    That's where the htm and html entries are pointing.
    If you expand that entry you should find a shell>open>command entry there which is where the command line for launcher.exe should be. Add the necessary switch to that.
    As donq says, there may be entries in other places too, but try here first.
    If you manage to correct the problem, export and save the Opera.HTML section of the registry (right click on it to see the options).
    Then if it ever gets changed by an Opera update you can simply re-import that saved file into the registry to fix it.
    :)

  • Ok, got it, except needed the Opera beta entry, as betas (only) are what I use. Here's what I used:
    "C:\Program Files\Opera beta\Launcher.exe" -alt-high-dpi-setting=96 -noautoupdate "%1"

    What is that "%1" do? It had to come last or the change wouldn't take. Thanks,

  • The "%1" variable represents the name of the file you're opening.
    When you double click on a file, or click on a link, Windows runs the associated program and passes the name of the file you're opening to the program, so if it's say "file.htm" Windows will replace the "%1" with "file.htm" and will send -
    "C:\Program Files\Opera beta\Launcher.exe" -alt-high-dpi-setting=96 -noautoupdate file.htm
    Glad you got it sorted. Don't forget to export the "Opera.HTML" section of the registry to a file, and then if it ever stops working, importing that file should fix it.
    Remember that the path will change if you start using non-beta versions of Opera.
    :)

  • Thanks! I suppose the "%1" has to be last because it refers to a file, which is the operable point.

  • Indeed so.
    :)

  • Not sure of the details of the command, but taskbar icons are actually shortcuts and can be edited. Just right click on the icon then right click on the name of the program and select properties. (I set up a desktop shortcut to try out the subject command and it did start Opera but I saw no difference.)

    Is there an index somewhere of Launcher command line parameters?

  • After I update Opera beta, it opens with the larger text, hence not invoking my --alt-high-dpi-setting=96 command, although it's still there in the registry (this is not affecting my desktop icon). Is there another place I should be looking, or is it in the nature of how Opera installs?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.