Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Video pop-out scaling problems and crash with YT clips

  • Description:
    After update to Opera 41 video pop-out started having following problems:

    • last size and position is not remembered, newly opened pop-out shows up much larger and partially off screen
    • pop-out aspect ratio is no longer locked (x,y dimensions of the window were locked to the actual video aspect ratio) which is much less convenient while resizing
    • using "Back" or "Reload" buttons on another tab causes pop-out to disappear (more than 50% of the time, however I do have ~25 different tabs open)

    Steps to reproduce:

    • open any YT video, activate and move/resize pop-out
    • open new tab with any website, click several following links in that tab, than use "Back" or "Reload" button, pop-out should disappear
    • go back to the tab with YT clip still playing, reopen pop-out, it will open with different dimensions than before

    Actual result: Listed above

    Expected result:

    • pop-out should not disappear
    • pop-out should remember last size and position
    • imo pop-out should have locked aspect ratio (although there might be an option to lock/unlock it in settings)

    OS:
    Windows 7 Professional 64-bit Service Pack 1
    Intel Core i5-3320M, 8GB RAM

    Version of Opera:
    41.0.2353.46

    Does anyone else noticed similar problems? I did the update today, can't remember my previous version and it might have been earlier than 40. However it worked much better before the update.

    Regards
    Rafal

  • I have had all the same issues you describe. Turning off hardware acceleration for the popout may help. See these posts:

    https://forums.opera.com/post/109369

    https://forums.opera.com/post/109411

    https://forums.opera.com/post/109445

  • Does anyone else noticed similar problems?

    Yep, it has been reported already.

  • Hi,

    Thank you for your replies. Disabling hardware acceleration fixed those problems.

    Regards
    Rafal

Locked