Googlemaps -- Mouse-cursor and mouse-click are pointing at two different places

  • WinXP, Opera 36. Yeh, that's another problem.

    A week or two ago, Opera started having problems with googlemaps. The mouse-cursor appears on the map in one place, but it waves-over and clicks in a different place. i.e., a couple of inches away, at about 309 degrees.

    It's hard to wave-over or click anything on the map when the mouse is actually active at a point that's different than where the mouse cursor appears. So I've lost most of the functionality of googlemaps.

    I've tried changing Opera zooms to Normal and 100% [in Settings]. I've tried changing my mouse from Big to Normal-Standard [in Windows]. Playing with those settings didn't change anything. There remains the same couple of inches dispacement, in the same direction, between where the mouse-cursor appears and where it actually waves-over and clicks upon.

    I had a similar problem with Firefox a few years ago. But normalizing the Firefox Page and/or Text zooms fixed the problem. Sorry the same trick didn't work with Opera.

    I would switch back to Firefox to use googlemaps, but that's a combination that's too hard on this computer -- googlemaps causes crashes if I try to go there with Firefox. In fact, the googlemaps-Firefox-crashing is exactly why I downloaded Opera.

    Any suggestions what to try next for Opera-googlemaps? Thanks.

  • Windows is set to 100% dpi?

  • I'm in Google Maps a ton of times. I've never had that happen. Although I'm on Win 7 on one computer and Win 10 on another and the latest version of Opera, 39.xxx.

    Here's what I would try first...

    Other browsers, IE, FF, Chrome. If it works in those, then its a Opera problem on your computer. If it doesn't work in those browsers then it could be the combination of WinXP and Google Maps.

    But this also might help. Is Google Maps in Lite mode? Go to http://maps.google.com. In the top left, click the Menu Menu. Go to the bottom of the page. If you’re in Lite mode, you’ll see a lighting bolt and a message that says "You're in Lite mode."

    When I run Opera 12.18 in Win 7 or 10 it runs in Lite mode. BUT, it doesn't display the behavior you talk about.

  • Hello leocg and rif.

    leocg wrote:

    Windows is set to 100% dpi?

    That's a setting I forgot to check. When I found it set to 125%, I thought we had something. So I set it to 100% and restarted the computer, but it didn't change the googlemap problem. I really thought it would work, although the antique laptop has been set to 125% dpi for ever, and the problem only started a couple of weeks ago.

    rif wrote:

    Try other browsers

    I can't believe I missed that one, also. Short story shorter, I opened Firefox, and googlemaps worked. The mouse points and clicks in the same spot using Firefox. So I have a work-around. So the Firefox-Googlemap combination will have to crash the antique laptop occasionally.

    Since I'm the only person on Earth having trouble with WinXP / Opera / Googlemaps, I guess I won't raise a stink. Choose your battles wisely.

    And since everyone needs a hobby, I'm going to spend an hour seeing if I can compensate for decreasing the dpi to 100% with the other Appearance settings.

    Thanks, Bosses.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.