Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

"opera was unable to open the link since no application associated with magnet protocol was found"

  • Magnet links work on all other browsers. Tried adding magnet to the exclusions in the Local State file, but that didn't change anything. Using Opera 20.


  • Do you have any example links? Last time i've tested, magnet link were working.

  • Window 7 Home Premium, Vuze 5.3.

  • Every link I've tried. How do you set magnet associations for Opera? It's been awhile since I used it, but it seems like there are fewer options in preferences. There's no "program" section, for example. I know you used to do it there.

  • Every link I've tried

    And there is at least one that you can post here?

    How do you set magnet associations for Opera?

    On Opera Blink (Opera 15+) there is no way to do that. But if a program is associated to the protocol, Opera will use it afaik.

    Edit: i've tried this magnet link from Wikipedia and Opera showed a dialog asking me if i wanted to open the program associated to magnet links.

  • I try that link and I get the same message.

  • I try that link and I get the same message.

    So it seems that Opera uses the default program to handle magnet links.

  • I guess I'll just cut and past the link into Vuze. Frustrating, though.

  • I've had this problem, solved alone, I long ago with this problem, do not know if the fact that I'm using the beta version of vuze has something to do with it.

  • I wasn't clear in my reply to leocg--when I say I get the same message, I mean I get the same message I got originally--that Opera can't open because there's no program associated. I did NOT get the prompt to open with the associated program that they received.

    But I've pretty much given up at this point. If it gets too annoying, I'll just switch back to Chrome.

  • I did NOT get the prompt to open with the associated program that they received.

    Do you have one? Try setting it on your OS.

  • Leo, I don't mean to seem ungrateful, but the very first thing I said was that magnet links work in all other browsers. Which makes it pretty clear that I've established the file associations for magnet links. I'm not going to change the association from Vuze to Opera because I don't want to download torrents with Opera, I just want to open the magnet link. Once again, IT WORKS IN EVERY OTHER BROWSER I USE.

    If you don't have any ideas how to do that, it's OK. But I feel like we're just wasting each others' time. I'm not a power user, but I'm not a newbie. I'm doing everything I'm supposed to do. It's not working. The fact that there's no clear way to set Opera to open a magnet link IS NOT USER ERROR.

    Sorry, but it's honestly less frustrating just cutting and pasting the link than it is getting advice from someone who's not paying attention to what I say.

  • Once again, the error message reads "Opera was unable to open the link since no application associated with "magnet:" protocol was found on your system."

    And once again, that is a lie. It's associated with Vuze. I've checked multiple times.

    Does anyone from Opera ever look at these forums? Help?

  • Maybe you should file a bug report.

  • @00sweeney
    Just to check: the exclusion list in Local State should have, "magnet": false
    Check the registry entries. Shoud be like this. Note that an existing and empty "URL Protocol" value is required.
    @="Magnet URI"
    "URL Protocol"=""
    "Content Type"="application/x-magnet"

    I've got μTorrent and magnet links work fine. As a last-resort solution you could try and install μTorrent just to set the association right and then change it to use Vuze in Registry.

  • I have utorrent installed and when I click that wiki magnet link I get this message:

    Unknown Protocol
    Opera was unable to open the link since no application associated with "denied:" protocol was found on your system.

    Below that message I get a button from Opera that says "Deny" and it's all I can click.

    OTHER magnet links on other websites DO work though. So maybe check that the magnet link being posted in this thread is good.

  • @pete8475 It must be just this forum that has marked the link with the unknown magnet protocol as denied/invalid content.

  • Pete, as I said, it doesn't work for ANY MAGNET LINK THAT I CLICK. I really don't know how I can be any clearer at this point.

    DVK--the registry solution doesn't explain why magnet links work in EVERY OTHER browser, does it?

    And I apologize for being a dick. I know all of you are only trying to help. But it's very frustrating when I'm very clear what I'm doing and people keep saying "Why don't you try this?" when I've stated--more than once--that I AM doing that.

    So, one last time.






  • I use μTorrent and Opera opens magnet links on it without problems.

    AFAIK, with Vuze, there's a bug. Even when Vuze is correctly set to handle the magnet protocol in the registry it doesn't work. I think Chrome has the same bug.

    I reported it as DNA-14953 already.

  • Please check the solution at

Log in to reply