Twitch video/audio out of sync.

  • Hello,

    So recently I've noticed that when I watch Streams on Twitch, the streamers voice is very out of sync with facial expressions. I've used other browsers and didn't have this problem. Other forms of video media are not affected, only Twitch.

    I've disabled Hardware Acceleration, reinstalled Opera, cleared cache/history/etc... but it didn't make a difference. I'm not sure why this is going on, and it happened completely randomly. Anyone have any ideas? I'm kind of stumped.

    Version: 38.0.2220.41
    System: Windows 10 64-bit

  • I've got the exact same problem with Twitch. Doesn't matter what quality you set the stream to, it has sync issues. Video is very jerky trying to catch up with Audio. Seems to only happen in full-screen mode though. Theater mode works fine.

    This doesn't however appear to be a problem when using Opera on my Mac.

    Version: 39.0.2256.43
    Update stream: Stable
    System: Windows 7 64-bit (WoW64)
    System: Mac OS X 10.11.6 64-bit

  • And as I post this I now all of a sudden have issues with all videos playing in full-screen. Note that I only had the Twitch problem up until Opera updated from 38.0.2220.41 to 39.0.2256.43

  • Another update. This is only an issue on my secondary monitors. Everything works fine on the primary monitor but as soon as I try watching video in full-screen on any of my other monitors I get very bad video lag.

  • Ok, so after extensive testing I've found the following.

    No problems when only one monitor connected to PC.

    Problems with two monitors plugged in, but only when one is plugged into NVIDIA GPU (GTX 960) and one plugged into MB video out. (Intel HD 3000)

    No problems with two or more monitors plugged into NVIDIA GPU only and visa-versa.

    This is with hardware acceleration on. With it disabled everything works fine again.

    So my problems started when I added an extra monitor and plugged it into my motherboard, not from the update.

    So is Opera using the Intel HD GPU when I have a monitor plugged into the MB instead of the NVIDIA GPU for hardware acceleration, and if so is there anyway to force it to only use the NVIDIA GPU?

    Sorry to hi-jack the thread here, not sure if my findings are related to OP.

  • Thanks a lot for in-depth investigation - this is really valuable as a real-life example of something which can not be easily reproduced in test environments. We'll take a look at this.

    In the meantime: I'm truly sorry to ask, but could you please check if the issue happens in Chrome or not? That would help us determine if it's Opera-specific or more general.

  • Just tested with Chrome now. While it doesn't seem as bad as when trying in Opera, I definitely get the same issue. If you need any log files let me know.

  • Wow, thanks! Would it be possible for you to log the issue to the Opera database https://bugs.opera.com/wizard/desktop then attach the logs and write the bug number here for the record (so it is easier to find)? That would be the easiest thing to share log files, I think.

  • Sure. Just let me know what you need and where to find them.

  • In fact, Opera does not log activities during regular usage, so probably something would be seen only if Opera crashed (then the crash log would occur). Since it is not the case, it'll be enough to just report the issue without log files.
    For future though, crash log files and installation log files land usually in the user's Temp folder (which is similar to: C:\Users[username]\AppData\Local\Temp)

  • I think Opera technicians have to look into it.
    See this sample website. (I wrote them that they had to look into it....Until after I found out it's Opera)
    It's still not oké. in 2017

    http://www.i24news.tv/en/tv/live

  • This topic is too old and seems unrelated to the comment above.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.