Problem with playing Flash Videos on Opera 35

  • Hi,
    I am having trouble with playing videos which use flash player in Opera browser. Here are my system details:

    OS: Win 7 x64 Home Premium Edition
    Opera Browser: v35
    Flash: v20 (latest one)

    I get a message "Adobe Flash Player is missing". What I have noticed is that the issue is mainly with embedded Youtube video links on forums. The same page along with video is displayed in Firefox browser. For some reason I am able to play videos from Youtube website from Opera browser.

    I always keep my flash player updated. I even ran the check from Adobe's website to see if Flash Player was installed on my system. In Mozilla Firefox browser, I was able to see the animation and Adobe says that I have the latest version of Flash Player installed.

    Of course on Opera, I get negative results. I typed opera://plugins in my browser and checked the list of installed plugins and I could see "Adobe Shockwave Player" v12.2.1 listed and it was enabled. I am unsure if it is plugin which flash player uses.

    I had faced this issue back in Opera 33 as well and I temporarily discontinued my usage thinking that it could be a browser issue. Sad to see that it is still happening with v35 on my system. Can anyone help me debug the issue?

  • Opera uses the PPAPI plugin that Chrome does, Firefox still uses the old NPAPI plugin. Go to the Flash download page using Opera and download the correct type, and Opera will work fine.

    https://get.adobe.com/flashplayer/

  • Thank you Sir for clarification on usage of correct type of Flash Player for Opera. That totally worked. I can use Opera again 🆙

  • I would like to mention that I too am having issues with flash content starting then stopping after a few seconds. Then is will start over and run fine. I am using v35 and I did the flash v20 download using opera and still have the same issue. Wonderful browser btw. Just is funky while using right now.

    Another thing I noticed with this issue is that on the videos initial start the volume is set to system settings, then when it has restarted it tones down to the volume settings being used in the player screen.

    Hope to get this figured out soon TIA

  • I have the correct Flash for Windows 7-64. I even re-installed it again, but Opera 39 still will not play flash videos on many sites that will work in Chrome.

  • I have the correct Flash for Windows 7-64. I even re-installed it again, but Opera 39 still will not play flash videos on many sites that will work in Chrome.

    Any examples of pages where Flash doesn't work?

  • Hello, i have problem with flash game wormax. I play it 14 day and now Opera sing only :- Page does not work wormax.io

    Web wormax.io you redirected too many times.

  • Opera is now almost in version 43. So please open another topic.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.