Strange Font Problem in Opera 12.17

  • This is a very long-standing and relatively minor issue, but I have a strange font problem in one of my main Opera 12 installations on Windows XP.
    I sometimes get a spurious "​" symbol appearing, sometimes next to images, and sometimes within the text on websites, especially on larger font sized headings.
    The strange thing is that I have four installations of Opera 12.17, two on Windows XP, one on Windows 98, and one on Windows 8.1 (64bit).
    This anomaly only appears on one of the Windows XP installations, the others show everything correctly.
    I assume it's an OS font problem rather than a problem in Opera, but strange it should only happen on one XP installation and not on the other!
    Anyone any suggestions what could be wrong?
    🙂

  • Do you have an example URL where it consistently appears for you (or does it not appear consistently on a site that sometimes offers it up)? There might be something in the source code or its links that could help lead to an answer. Also, if it ever reappears, what happens if you pull the same site page up at the same time using another browser like IE, FF, etc?

  • Thanks, there's one here which shows the problem for me on several thread titles.
    For instance "disappeared" appears as "disappeare​d" in two places, "advertising" appears as "advertisin​g", "subscription" appears as "subscripti​on", and "unavailable" appears as "unavailabl​e".
    The "​" symbol does not replace any letters, it's inserted into the words in addition to the normal letters, which are correct.
    This only happens on one Windows XP installation of Opera 12.17. My other three installs of Opera 12.17, including one on the same version of Windows XP on another computer, display the words correctly.
    🙂

  • In the page elements containing each of your problematic words, there's a <wbr> symbol (an HTML 'word break opportunity' element) inserted within the problematic word text. This is supposed to optionally break the text line for a long word at the symbol's location without showing a hyphen, if the browser wants to employ a break in order to properly organize the text in its then-current screen display size. It's my understanding that Opera ought to exhibit compatibility with this symbol (and your other installations confirm that), but that doesn't mean it's working or responding properly to the symbol in the problematic Opera installation. If that Opera installation isn't correctly recognizing the HTML word break symbol, it may instead be combining or interpreting it in some other way that causes a "" to display in the word.

    You might want to check the problematic Opera's encoding setting (Menu > View > Encoding) and make sure "Automatic Selection" is enabled.

  • Since I'm not seeing any symbol here (in your own posts), I have to presume it is one of those optional characters ... yes, looking at the source shows me a "wbr" (in braces) in the middle of the word. We've had this one before - years ago. Unfortunately with the older posts gone, I can't find exactly how we solved it before ... I think it was something with user CSS, but I've never been a CSS guy.

  • @sgunhouse's post jogs my memory a bit further. So you may also want to check the problematic Opera's settings at: Menu > View > Style > make sure Author Mode is selected. Also, check at Menu > View > Style > Manage Modes > Presentation Modes > make sure Page style sheet, Page fonts and colors, My style sheet, and My link style are enabled > OK. If the installation has a user-custom css style sheet being used, you might want to try the Presentation Modes with "My style sheet" DISabled instead and see what happens. I vaguely recall some of these kinds of things were impacted by these various settings in the old days. Unfortunately, I've no longer kept some of my detailed notes from back then.

  • Thanks guys!
    "Automatic selection" isn't selected under "Encoding", and if I select it the page refreshes but nothing changes.
    Strangely, if I close the page and re-open it, "Automatic selection" is de-selected again, and nothing in the menu appears to be selected.
    Is that normal behaviour?
    😕

  • Hmm. Mine does that as well... so it must be normal behavior. 😄 As I noted earlier, it's been a long time since I messed with the bowels of these settings in Olde Opera... I pretty much use it as-is the way I've got it set up and that, for reference only; some of the fine-level behavioral details like this disappearing-setting thing have faded from my memory.

  • I'd already checked out the author mode/user mode setting, and the various options under them, but no setting seemed to make the problem go away.
    Also, I'm pretty much certain that the settings are all the same on the version that has the problem as they are on the other XP version that doesn't!
    I will run them up side by side again and have another look to see if there is any difference between them.
    🙂

  • Hi again. Well this is very embarrassing!
    :doh:

    I've just checked again on my other machine, and the Opera text display on Windows XP there is exactly the same as on the first machine, with the spurious characters.
    However, it's a dual-boot machine, and if I reboot into Windows 8.1, and use exactly the same installation of Opera, which is the only one on the machine, the display is normal!
    So, it looks as if the problem is actually operating system related, and only happens on XP.

    So sorry for all the confusion, It's been a long time since I actually last checked the other XP installation, and I was obviously mis-remembering the scenario, and I didn't bother to check that what I was saying was actually true.

    So, it only happens on Windows XP. It's fine on Windows 8.1 (two installations, 32 bit and 64 bit) and even on Windows 98. Is that any sort of clue?
    Cheers, Dave.
    🙂

  • Back in 2010 (around the time of Opera 10+), an article was published showing that Opera indeed had compatibility problems with the <wbr> symbol in text. http://blog.301tool.com/2010/05/breaks-in-unbroken-text/ According to that article, the <wbr> symbol redered as a small, empty box in the text location of the symbol. The author proposed a fix that included placing the following in the page code:

    div { word-wrap:break-word;}

    wbr { display: inline-block;}

    This essentially tells the browser to interpret the <wbr> term diffently within its brackets than otherwise, using a new term that won't cough up the odd character. Perhaps 'user CSS' could be made to employ this somehow, though I'm not a CSS guy either. It's only a guess, but I suspect that the reason you're getting the "" instead of a small box has to do with the font being used by Opera in XP. With another OS, the font may render slightly differently (ie: not at all) when that character is called by Opera as it encounters a <wbr>.

  • Thanks @blackbird71, that sounds like exactly it, although why it should apparently only happen on Windows XP and not on Windows 8.1 with an identical Opera setup is still a bit of a mystery, but as you say it's probably to do with the OS fonts!

    I will do some CSS experiments and see if I can incorporate that code into Opera for all websites.
    🙂

  • While it may be the same program, do they use the same profile? For an "all users" install, XP and 7 would have different paths for user data. Of course if it is a standalone/USB install there's no need to check, but it could explain things otherwise.

  • @davehawley

    Also, there are well know problem with Web Fonts in Opera 12.

    1. You can to disable these fonts globally (for all web-sites). Go to opera:config#UserPrefs|EnableWebfonts and uncheck the flag. Restart Opera.
    1. You enable/disable Web Fonts selectively for a certain web-sites via override.ini

    [web-site_with_a_promlem.com]

    User Prefs|Enable Webfonts=0

  • @sgunhouse

    It is a standalone installation, everyting is in the Program Files\Opera folder.

    @stng

    Thanks, a good thought, but I'm afraid that disabling web fonts makes no difference to the problem.
    😞

    I'm working on trying to implement those suggested lines

    <style type="text/css">
        div { word-wrap:break-word;}
        wbr { display: inline-block; } /* fix for IE8 and Opera */
    </style>
    

    for all sites using CSS, but I'm not having any luck so far.
    I'm afraid I know very little about how to use CSS.
    🙂

  • Well, try as I might, I don't seem to be able to fix this.
    😞
    According to the earlier link, the problem quoted there should affect Internet Explorer 8 as well as Opera 12, but it doesn't. The display is correct in IE8.
    I'm fairly convinced that it's actually something to do with the system fonts, but I copied all the Windows 8.1 fonts to Windows XP, and the problem was still there.
    Looking at the source code for that Sky site here in Notepad, the spurious characters appear as question marks.
    It appears to be using downloaded Sky propriety fonts such as "SkyTextRegular". I downloaded all the variants of that font and installed them on the OS. No difference.
    So now I'm at a dead end. I guess I'll just have to put up with it unless anyone can suggest anything else to try.
    🙂

  • Well I've fixed it, or at least found a workaround!
    I had that Sky Help Forum site set to mask Opera as Internet Explorer, I assume because of some problem with it in the past.
    I can't remember why it had to be set like that, but just to experiment I set it to mask as Firefox instead, and the font problem went away!
    So, assuming that not masking as IE doesn't cause other problems I've not found yet, that's the answer.
    So simple, and now I'm kicking myself that I didn't try that in the first place!
    :doh:

  • Actually, the whole business is not simple, so stop kicking yourself. The problem actually was and is quite subtle and rather complex; and you didn't actually "fix" the problem as much as you've (apparently) found a practical way around it. So... good for you!!

  • Thanks!
    Certainly the blog post you pointed to earlier on suggests that this is a problem that shows up in older versions of Internet Explorer and Opera, so masking Opera 12 as IE or leaving it as Opera could well make it appear, although as I said earlier the problem doesn't actually appear on IE8, at least not on my system!
    Anyway, as long as it doesn't cause any other problems I'll leave things as they are. I haven't actually tried posting to that Sky forum since I changed the setting, but it now certainly all displays OK.
    Cheers, Dave.
    🙂

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.