Opera 34 freeze every 20-30 minutes (windows 7)

  • Hi, I updated last 2 versions of Opera v34, it freezes every 20-30 minutes,
    I have to force-close and restart, then Opera works for 20-30 minutes and freezes again

    I have about 30 tabs opened concurrently, but only 5-6 are really active (yahoo mail, google, amazon, ...)
    I saw the other post regarding 30 secs freezing, but it waited several minutes (on 2 freeze-scenarios) without update/restore of normal behaviour.

    pc Windows 7 Pro, cpu I5, ram 8GB

  • Do you see any error messages in the Event Viewer at the time Opera locks up? Do you have any extensions installed in Opera?

  • Hi
    thank you for coming back to my post.
    I see no event viewer logs relevant to Opera lock (when I force-close Opera, it is logged in Application Event log...)
    AD Block Plus installed as extension,
    Turbo Mode is always on
    I see several Opera.exe processes (less than 10 proces), but only one working at 25% (1 core of 4, cpu I5 ...)

    any additional infos?
    any internal/debug window I can keep monitored, in order to provide some detailed info?

    Thx
    BR

  • Turn off Adblock Plus and see if that helps. Also try turning off Turbo. Are you on a slow or metered connection? If not, you shouldn't be using Turbo anyway.

    I see several Opera.exe processes

    That is normal.

  • Hi
    thank you for your feedback.

    1st test: disabled Turbo
    result: 1hour test and so far, so good

    unfortunately I am on a slow connection (mobile), with 1 GB included (up/down).
    once reached that quota, I have to pay KB.

    Is there anz way I can monitor Turbo feature? memory, network bandwidth, ...

    BR

  • Hi it seems to be Turbo Mode the root cause of those block.
    I re-enabled it and within 20 minutes I got a Opera freeze.
    I need Turbo mode, and cannot use other browsers.

    is there any way to detect if a freeze is going to happen?
    Which parameter may I monitor? anything else I can do in order to avoid Turbo mode?

    BR

  • anything else I can do in order to avoid Turbo mode?

    Just don't enable it.

  • 😄

  • Same problem, but it disappear after disable hardware accelerator.

  • Hi I come here again, for a quick update.
    it seems that the problem i reported has disappeared.

    I was used to turn on/off Turbo mode every half hour, however left it turned on for a while and no crash happened (so far ... knock wood!)

    what can you tell me about this behaviour ?
    was Opera browser on my computer or Turbo Mode servers or ... ?

    BR

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.