Extremely slow filedialog - Opera 34 - Win7 x64

  • After having done a windows system cleanup, Opera and Chrome ran into problems. I do not have any system restore points either.

    Opera v34.0.2036.25 on Windows 7 SP1 - x64

    When performing a download and the Filedialog/File-Explorer shows up, it behaves and populates extremely slow, 10 to 15 seconds sometimes even longer. Browsing to different folders or drives have the same result.

    Reinstalling a fresh chrome browser fixed its issue. Opera however remained with a laggy filedialog.

    Maybe something broke/went-missing on the Windows side but i haven't noticed anything strange other than the opera issue, all my other installed programs work fine (save, saveas... etc...)

    What files should i be looking for? What system does Opera rely upon? Isn't it weird that Chrome works fine and not Opera since they both rely on the Chromium system if i understood correctly?

    Anyways, I tried an earlier portable version of opera, and the filedialog works fast and flawlessly: Portable Opera v12.17 - Build 1863. But the portable Opera v33.0.1990.58 has the same laggy filedialog issue.

    NB: Latest Firefox, IE & Chrome all work fine.

    TIA for any tips or suggestions!

  • good afternoon

    I also start to slow down all the terrible
    as it is written on top

    Opera 33 Windows 7 SP1 - x64
    has fallen the day before.
    I can not open an opera setting. long boots. She writes that the error on the page.
    there were laid important passwords for sites. everything is lost!
    as extensions instead of icons appeared gray icons, too, I can not open it.
    bookmarks have names, but the site does not open.
    need expert help, please help !!! I use Opera for many years, but this is a huge mistake for the first time!
    LB

  • Opera v. 42.0.2393.94
    Windows 10 64-bit (WoW64)

    Very slow file open dialog!

  • This topic is too old. Please open a new one following this guide

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.