How to ignore certificate error?

  • I have a NAS on my home network. Every time I access certain apps via my browser, I get a certificate error. Is there a way for me to say "always ignore" error or similar in Opera?

    Having to click through the error every time is really annoying.

    Thanks 🙂

    Full warning text: "Opera cannot verify the identity of the server "XXXX", due to a certificate problem. The server could be trying to trick you. Would you like to continue to the server?"

  • Hi @ervler, you can go to opera:flags#remember-cert-error-decisions, select e.g. "Remember for one month", or "Remember for three months" from the drop-down, and restart the Opera 😉

    Alternatively, you can try to run the launcher.exe together with the command line switch as follows:

    path\to\launcher.exe --ignore-certificate-errors

    If it works for you, then you can add it at the end of the shortcut to the launcher.exe file (do not forget to add a space, preceding the switch).

  • Hi l33t4opera, remember-cert-error-decisions (very useful option) absent in OperaNext now. Is it mean it will be removed in Opera stable soon?

  • Is it mean it will be removed in Opera stable soon?

    Yes, most probably.

  • In opera 39 stable you cann find this entry in opera:flags
    chrome://flags/?search=cert#allow-insecure-localhost

    Activate the entry and you should be golden, if not, then something else is wrong wwhen you access your NAS.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.