Can't set Google As Default Search Engine

  • I have downloaded the Google and even the Pirate Bay Search Engines and they are both running, yet neither one of them are showing up as an option in Setting under Manage Search Engines! I have no idea what is going on and I would like to know why this is happening so that I can go ahead and get this working like it should be. I hate all the other choices you have in there as search engine options and find it annoying that with Google being the largest search engine in the world that you would conveniently leave them off your list as choices! To me, this leave a very sour taste in my mouth with your company and makes me wonder if you really care what your customers really might want! At least when Microsoft does this, you can easily add the Google Extension with no problem and it works! You can then make it your default and even go as far as deleting all the other search engines!

    Anyway, would like to get an answer or a fix on this problem right away!

  • You can only set one of the "pre-installed" search engines as the default one.

  • Why do they even give you the choice to add the Google Search Engine as an extension when they don't even allow it to be used let alone even be seen in the list of choices?!

  • Why do they even give you the choice to add the Google Search Engine as an extension when they don't even allow it to be used let alone even be seen in the list of choices?!

    Uhh, Google is the default search engine in Opera. It comes that way out of the box.

  • It is in English, I believe Yandex is for Russian ...

  • That's crap.
    There must be an international version. Right?
    A user mustn't depend on their location anyway: let alone confident geeks, there are travellers, businessmen, who don't want to get everything in Thai when they're occasionally in Thailand.

  • I bet its tied to the default language of your OS. I doubt it would use location alone as that can change and doesn't necessarily having any relation to the language you speak.

  • No it uses location, I guess the gateway IP to set the search engine.

    So I am in China, the search engine is mother fxxxxxxxxxxxxxcking hoodlum Biadu. Fxxxxck it! I can't even change the search engine.

  • We have previously changed the saved location, you might give that a try. Go to your profile (as listed in About Opera) and edit the file Local State (yes, with a space in the name and no extension - it's just text so Notepad will work). Find where it says Country, mine reads

    {"country":"us","country_from_server":"US","timestamp":"1419298826600000000"},
    

    (not certain why they removed all the line feeds since I first posted this tip)

    If you want Google, you can change it to US like mine (I'd leave the timestamp alone). Be aware, Opera may change it back to your real country eventually. And of course, don't edit the file while Opera is running - at best, Opera would just overwrite it when you closed the program.

  • Steve, are you sure the Chinese authorities won't get to him for that?
    ;)

  • Why do they even give you the choice to add the Google Search Engine as an extension when they don't even allow it to be used let alone even be seen in the list of choices?!

    Uhh, Google is the default search engine in Opera. It comes that way out of the box.

    This is the most ignorant statement made here! First of all, I am from the US and my Opera is set up as being from the US. Second, the default search engine is not Google, it is Yahoo and is not even one of the Search engine choices! I can't stand morons like yourself that would assume that someone like myself must be an idiot. Now if you did any checking into the Opera browser, you might have found out that in its newest release that they dropped Google as its Default browser but no, you just jumped the gun and assumed that I was an idiot and instead proved yourself one!

  • We have previously changed the saved location, you might give that a try. Go to your profile (as listed in About Opera) and edit the file Local State (yes, with a space in the name and no extension - it's just text so Notepad will work). Find where it says Country, mine reads
    {"country":"us","country_from_server":"US","timestamp":"1419298826600000000"},

    (not certain why they removed all the line feeds since I first posted this tip)
    If you want Google, you can change it to US like mine (I'd leave the timestamp alone). Be aware, Opera may change it back to your real country eventually. And of course, don't edit the file while Opera is running - at best, Opera would just overwrite it when you closed the program.

    You must have one of the older versions of Opera. So far I can't even get Google recognized as an option even though it is seen as a downloaded plugin.

  • This is the most ignorant statement made here!

    No, this is not. Google is the default search engine for the majority of the users.

    In some countries the default search engines and the default speed dials may be different.

    First of all, I am from the US and my Opera is set up as being from the US. Second, the default search engine is not Google, it is Yahoo and is not even one of the Search engine choices!

    Don't know if Yahoo is the default search for the installations made in the US but i think it's very strange to not have Google listed as one of the default search engines.

    Now if you did any checking into the Opera browser, you might have found out that in its newest release that they dropped Google as its Default browser

    You mean default search engine, right?

    Btw, which are the defaul search engines in your install?

  • Google is still default in the latest builds for Windows desktop (which is the topic of this thread) in both Opera standard and Opera developer - and I am in the US.

  • Steve, are you sure the Chinese authorities won't get to him for that?

    I went to China last year. Can't use Google in China AFAICT. Perhaps with some creative routing...

    For using other search engines and language versions, check out the following post.
    https://forums.opera.com/post/47749

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.