Click to play setting fails; YouTube videos play automatically.

  • Click-to-play suddenly stopped working when I launched Opera today. YouTube videos now simply play automatically, which drains my download allowance. I didn't change any settings recently, and I checked to verify that Settings; Plug-ins - Click to Play is still ticked.

    I have Windows 8 on a pc, and my current up-to-date Opera version is 30.0.1835.59.

    Please help.

  • It's because Youtube is no longer using Flash to play the videos.

    You will need to use an extension to avoid autoplay

    Remembering that the video is/can be downloaded even if it's paused.

  • I have indeed found an extension (M.A. for YT) that stops the autoplay.

    As someone who really doesn't like using add-ons (since I'm aware they tend to cause unexpected problems), I'm disappointed that the browser can't prevent HTML5 as well as Flash from autoplaying, and finding it difficult to believe that this 'problem' lies solely with YouTube. I think that browsers have deliberately made it harder to restrict video play, probably to please ad-distributors. Click to Play still works on Opera 12.17, and doubtless Opera 30 could control HTML5 play if they wanted to.

    YouTube's switch to HTML5 as default occurred early this year, and it's been a couple of months or so since I had to install an add-on for Firefox forcing it to play Flash on YouTube, to work in conjunction with the Click to Play add-on I already had. (Firefox had discarded their built in click to play feature long before then.) So, it's odd that only now does Opera lose this capability.

    Also, I see other new threads here (e.g. this one) reporting more serious problems related to YouTube, occurring with the update to version 30. I suspect that click to play works fine on 29, but can't test this.

    In short, I think that our inability to stop auto-play is more or less intended, and this is unfortunate.

  • the browser can't prevent HTML5 as well as Flash from autoplaying

    Flash is a plugin, HTML5 is not. Thats why it can't stop it.

    Click to Play still works on Opera 12.17

    Thats because when you go to YouTube with Opera 12 is loads the Flash version.

    So, it's odd that only now does Opera lose this capability.

    Opera never had the ability to block HTML5 video. Its not a video specific thing, its a plugin specific thing.

    Also, I see other new threads here (e.g. this one) reporting more serious problems related to YouTube

    Thats just related to the 30 release and has already been fixed.

    In short, I think that our inability to stop auto-play is more or less intended, and this is unfortunate.

    Its not.

  • Flash is a plugin, HTML5 is not. Thats why it can't stop it.

    Interesting distinction, but the extension mentioned above does stop it. I doubt its developer is smarter than Opera's developers.

    Thats because when you go to YouTube with Opera 12 is loads the Flash version.

    If Opera 12 can do it, then Opera 30 could do it, if desired.

    Thats just related to the 30 release and has already been fixed.

    The sudden failure of Click to play may also be related to the 30 release, and may also be fixable.

  • Interesting distinction, but the extension mentioned above does stop it. I doubt its developer is smarter than Opera's developers.

    It's a different mechanism. Click to play (in Opera) is designed to stop plug-ins (it's also listed under "plug-ins" in settings), and as said before, HTML5 video means no plug-in is used, which means the click-to-play mechanism simply doesn't come into play. Of course Opera could develop an additional feature to block HTML5 videos unless clicked, but that should be much easier to do in an extension now.

    If Opera 12 can do it, then Opera 30 could do it, if desired.

    Opera 12 isn't doing it; YouTube doesn't serve HTML5 videos to Opera 12, it serves Flash to Opera 12.

    The sudden failure of Click to play may also be related to the 30 release, and may also be fixable.

    This again is not related as such to the Opera 30 release: it's just that YouTube serves HTML5 video by default to Opera 30 and newer. For earlier versions of Opera YouTube serves Flash, and you can opt-in (with YouTube!) to get HTML5. It's completely up to YouTube what content they want to serve.

  • Thank you for the informative response. I'm concerned that apparently you do not intend to restore Click to play (for HTML5) as a built-in feature, but I guess this will be okay as long as you facilitate the necessary extension. Please continue to do so.

  • Click to play was never available for HTML5, so it can't be restored.

  • Click to play was never available for HTML5, so it can't be restored.

    You are employing a narrow, technical definition of Click to play in order to make your argument that "it can't be restored". When I discuss Click to play, I'm obviously concerned with its functionality, not its internal processes. The player software difference is not even evident to a user who only clicks to play and view videos. I'm obviously aware now that a restored Click to play would not have the same internal processes as the previous Flash version. That doesn't mean that the Click to play feature as I know and use it couldn't be restored.

    And as I said before, Click to play could also be restored via having Opera 30 set to use Flash for YouTube, as Opera 12 does; again it would obviously require different internal processes. In fact, I've found that simply setting Magic Actions on Opera 30 to Force Player Type: Flash (without even setting Stop Autoplay) restores Click to play functionality.

  • Balls. Someone mentioned an extension to block YT html5 autoplay, but I haven't stumbled upon one. Anybody have a link?

    • "Stop Youtube HTML5" seems to work, although the permissions are kind of unsettling.

    ** For chrissakes. Magic Action, which I already have, handles this just fine. I should probably have more coffee before troubleshooting.

  • @jessejoh Wow, I haven't seen someone distort the realities of the universe to fit their worldview like that since I left the military. Bravo. I can't imagine the mental acrobatics it must take to pull something like that off.

  • Since changing from opera 29 to 30, I now cannot stop youtube videos from starting. Open any new youtube video and it will start whether I have the page open or not. This means that if I open multiple youtube video in new tabs, they will all play. I have checked the box to click to play in settings, I have turn off autoplay. Nothing works. Only thing that I can do to get everything to work as before is to revert back to version 29. Can this be fixed, because it is bloody annoying.”

  • Can this be fixed, because it is bloody annoying.

    There's nothing to be fixed. YouTube is no longer serving Opera with the flash player, so there's no plugin for the click to play option to work on.

    There are extensions that can block the autoplay even in the html5 player.

  • I worked it out. Got Magic Actions to work. Thanks

  • Autoplay works on the YouTube web page. I have tried Magic Action with no success. Need to find a way to prevent the YouTube video from playing until I want it to start. Can anyone make some suggestions. Thanks.

  • Maxvelocity, have you tried adding the Magic Actions extension? It works like a charm for me. You set its Options either to Force Player Type: Flash, or set Stop Autoplay (in which case you'll have to click a video twice).

  • Click to play in settings only works on plugins. If you have YouTube set to feed you the HTML5 version of the website then it wont use the Flash plugin for the video and Opera wont be able to block it. Either switch back to using the Flash version of YouTube or download an extension for Opera such as Magic Actions for YouTube or some such.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.