@leocg Hi. That was the latest version of Opera when I installed it about a year ago. It works fine. Why would I want a newer version?