@sgunhouse Thanks. I did try that. what i ended up doing was going into the folder where the launcher was, make a new shortcut and add the start maximised flag to the end of the command. I was able to get the browser to show on my screen then. I just dragged from the top of the browser to unmaximise and all is now well again!