Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Cannot drag and drop files to GMAIL

  • Do I realy have to go back to an other browser?

    I've checked on stable 35 and developer 36 and it seems to be working here. You need to click on the "attach photos" button and then on upload.

  • Leocg, if you "need to" to click the button, then your drag-and-drop isn't working either.

    The whole point of the drag-and-drop feature in Gmail is that you don't have to click that paperclip icon. You just drag the file from your desktop directly into the Compose window, wait one second for Gmail to realise that you're going to upload something, and then let go of the mouse button.

    It works fine in Firefox. The same applies to -- previously, I could drag an image to the search box, but now I have to use the paperclip icon and navigate to the image on my hard drive. If I drag-and-drop to, then Opera opens the image itself. If I drag-and-drop a file to Gmail's Compose window, then Opera offers to "save" the file.

    I've had the problem in Windows 8.1 for the past 2-3 weeks, and this week I'm back on Windows 7, and the functionality is still missing (using the latest Opera).

    [A slight workaround for is that you must click the camera icon, then click the "Upload an image" tab, and then drag-and-drop the image onto the "Browse" button. This saves you from having to navigate to the image on your hard drive. But this is really just a workaround, since in Firefox you don't even need to click the camera icon before dropping the image into the search field.] I know of no workaround that works with Gmail.

  • same problem here ! problem also on the google image search (you can upload an image to search same pictures)

    Version :35.0.2066.37 - Opera est à jour
    Flux de mise à jour :Stable
    Système :Windows 7 64-bit (WoW64)

  • i've checked on my win10 computer, same problem ! why are the most usefull things not working ?

  • Leocg, if you "need to" to click the button, then your drag-and-drop isn't working either.

    Ok, seems to work if i change the user agent to Chrome's one. So it looks like another browser sniffing issue.

  • hello ! @leocg how to change the user agent in Opera ? with an addon like shown on Google ?

  • G'day Leocg

    I tried changing the user agent as well, but that didn't work. Can you tell me what the user agent string is that you're using, please?


  • Sputnikk, I use ltworff's DomainUserAgent:
    It doesn't always work -- some sites are too smart for it.

  • Hi, we deployed browserjs patch for Gmail. It is online. Make sure that after visiting it states the following:

    Current browser.js status: enabled.
    Target version and time stamp of the active browser.js file is Opera OPRDesktop 28.0 core 1750.0, February 8, 2016. Active patches: 24 .

    If not, restart your browser, it should download the patch shortly after restart.
    We also are in touch with Gmail team, so they can fix it on their side.

  • thanks for looking on this @mmitek ! for me problem fixed on gmail but not on google image upload. (and thanks so far, gmail attachment is the most usefull thing)

  • I had the same problem last week. After few days I noticed the issue was only happening to my (gmail) personal account. My work account (also gmail) worked without any issue.

    I solved it by accessing gmail with labs deactivated. Simply follow this link:

    (You can find it in Gmail > settings > labs).

    After that check if drag and drop works. To enable labs again, remove the "labs=0" from the address bar and reload the page again.