:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Ctrl-click doesn't work

  • It seems that ctrl-click does not work in the recent versions of Opera. How do I open the context menu, for example to search for a selected phrase on a page? Is this a bug?

    Wouter

  • Control–click, double-tap, and right-click all seem to be working. Is it any particular page? Review your System Settings: Trackpad and Mouse.

  • Thanks for your reply. I have a one-button mouse (traditional Apple design), and ctrl-click works in the Finder and all other apps. It brings up a menu in the Opera tab bar, in the address bar, in the bookmarks bar, but not in the page window, regardless of the website displayed. Not on a link (for example, to Open as new tab) nor on selected text, nor on images. What can I do?

    Wouter
    Opera 28.0.1750.51
    Mac OS X 10.10.2

  • Does it work outside the web page (but within Opera)? For example, if you Ctrl+Click on a tab at the top, do you see the context menu?

  • Yes, it brings up a menu in the Opera tab bar, in the address bar, in the bookmarks bar...

  • Confirmed, for about 3 weeks I experience a lot of problems with context menu within browser viewport. No problems with UI like address bar, but it often breaks on webpages. Reloading does not help, opening the same page in new tab does the trick for me, but it's very annoying. Cmd-C and Cmd-V does not work too in such cases. I haven't found any STR and it looks like it's not connected with any particular website.

    Some versions:
    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.82 Safari/537.36 OPR/29.0.1795.41 (Edition beta)

    Extensions:
    Imgur

    Plugins:
    Imgur

    Mouse gestures, special mouse gestures and advanced keyboard shortcuts are enabled. HW acceleration is selected too. Using Macbook Pro, Late 2013.

  • @wouterb:

    Yes, it brings up a menu in the Opera tab bar, in the address bar, in the bookmarks bar...

    Do you have this problem always (from when Opera is started) or does it start occurring after some time?

    @mbaluta:

    Confirmed, for about 3 weeks I experience a lot of problems with context menu within browser viewport. No problems with UI like address bar, but it often breaks on webpages. Reloading does not help, opening the same page in new tab does the trick for me, but it's very annoying. Cmd-C and Cmd-V does not work too in such cases. I haven't found any STR and it looks like it's not connected with any particular website.

    Do you know when this starts happening? Does it happen frequently on specific sites?

    As a workaround, try Cmd+W, Cmd+Shift+T (close tab, reopen last closed tab). It's quicker than opening the same page in a new tab.

  • Restarting does not seem to work for me; meither does closing and reopening the tab.

    Wouter

  • I don't know when it happens. I notice this most often on Facebook, probably because it's the site I visit most often and most often I open pages in background. As for my other habits I usually have 2/3 windows open (all kept on the 1st virtual desktop), each with around 5-20 tabs. Usually I switch tabs using Cmd-Tab, Cmd-Shift-Tab. I have usually 2-4 virtual desktops in OS X and I switch often using 3 fingers swipe gesture. Usually I have some PDFs open too.

  • New version of OS X, new version of Opera, still the same problem. I think I should file a bug report.

    Wouter

    Opera 29.0.1795.47
    OS X 10.10.3

  • New version of OS X, new version of Opera, still the same problem. I think I should file a bug report.
    Wouter
    Opera 29.0.1795.47
    OS X 10.10.3

    We already have this one filed as DNA-37878, but so far no one has been able to reproduce it. Can you try using a clean profile to see if that makes a difference (move away ~/Library/Application Support/com.operasoftware.Opera to try, you can move it back later to restore it)?

  • I think I've found 100% STR:) I noticed that when page is loading it may take a while until it's possible to open context menu, so that gave me a clue.
    Tested with clean profile in Opera Developer (Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2351.3 Safari/537.36 OPR/30.0.1835.5 (Edition developer))

    1. Load wikipedia.org in first tab
    2. Open new tab
    3. Start loading any page (I reproduced with "bbc.co.uk", "dn.se" and "www.google.pl")
    4. Switch to previous tab before page starts loading
    5. Switch back to BBC when it's loaded (spinner disappeared)
    6. Try to open context menu
  • Thank you so much @mbaluta, I just tried this and it's reproducible! Adding it to the bug now, expect a solution soon. I'm hoping the cause of this problem is the same as @wouterb's.

  • Can you try using a clean profile to see if that makes a difference

    It did; with a clean profile the context menu did appear. Thanks for the suggestion; I will export my bookmarks, start with a clean profile and import them again. I'll let you know if it works. I'm not sure whether it's the same as mbaluta's, but it might be related.

    Wouter

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.