Mails are (not) sent, remain in Outbox for ever

  • Opera mail is the best of all mail programs I have used so far. I have about 12 mail addresses and also for Opera Mail is very convenient. But with one mail account I have a problem: Mails are not sent, remain in the Outbox for ever, or are sent many many times while they remain in the Outbox. There should be no problem with the setting as I tried all of them and also the password is correct. I was using Thunderbird, Becky!, and also Ms Outlook etc. and never had this problem. I guess it's a bug in the software. Or what would you say?

  • If it is only one account, then there is something about that account. You haven't said enough for us to tell what yet.

  • Whether you did it before or not, retype the username and password on the servers tab in the account's properties. You might even want to change the password to something else, close out of the account's properties and go back in and change it again.

    Make sure the port is 465 or 587 with TLS checked.

    If you have an anti-virus email scanner, turn that off to see if it makes a difference (even if it doesn't interfere with Thunderbird).

    Turn on logging and see what the log says when there's an error. If nothing is in the log, that means Opera didn't get that far and it's something with the UI that broke like an error in the syntax of one of the addresses or the value of the To, Cc or Bcc field is too long.

    In "All Messages/Outbox", click the "settings for this view" button on the message list toolbar and goto the "show" section. Make sure "show sent" is checked. Or, check them all just to see if any new unsent messages show up. Then, wipe out all the Outbox messages to rule out one of them causing a problem.

    Check your windows hosts file to make sure there are no invalid entries.

    Most likely though, the log will tell you what's up.

    Does the smtp server require a self-signed cert?

  • Thank you all for your comments.

    I have set the port to 587 but did NOT check TLS.

    Now, the mails are sent out and the Outbox is emptied.

    Incoming POP Server is set to 995 with TLS checked.

    Thank you

  • Awesome. Try with TLS checked (on either 587 or 465) though so that you're using a secure connection.

  • That's what I also was thinking about. So I tried again and found out the following:

    It depends whether there is an attachment or not.

    Port 587, without TLS: mails with or without attachment are sent.
    Port 587, with TLS: mails with or without attachment are NOT sent.

    Port 465, without TLS: mails without attachment are sent.
    Port 465, without TLS: mails with attachment are NOT sent.

    So, only 587 without secure connection is ok.

    I asked the people from the server company and they asked me to try without security software. So I switched off Kaspersky, but there was no change.

    They also gave me other server numbers but no change...

    I checked again with other mail programs. With Outlook and Thunderbird it is the same.

  • Hi! I'm back again.

    As sgunhouse said there must be something about that account.

    I didn't realize it because I was using the mail program "Becky!" for this account and there was never a problem with the TLS setting.
    (There might also be another problem with this (old) mail program.)

    I contacted the mail provider but they couldn't solve it. (They even suggested to switch off the router and switch it on again after a while....)

    We'll look for another email provider.

    !! No problem with Opera Mail !!

    :bye: :bye:

  • So I switched off Kaspersky, but there was no change.

    Including its email scanner if it has one? It kind of sounds like an anti-virus email scanner is interfering, but since you tried disabling it, I don't know. But, if the email scanner is scanning your messages, you'll want to connect insecurely so it can scan your messages. Then, the email scanner SHOULD connect you to the server securely. Or, if you use TLS in Opera and have an email scanner scan your messages, you might have to accept some certificates from the email scanner so it can man-in-the-middle you to scan your messages. However, I'm not sure how Kaspersky does things. Maybe there are some settings in it for configured email ports etc.

    So, you can investigate that if you want before looking for another email provider.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.