[Opera 28] ''GPU Process Was Unable To Boot''

  • Opera://GPU Diagnostic:

    1

    Can anyone explain me why I'm getting this message from the Opera:GPU page? It started happening after the update to Opera 28.

    The whole Opera UI is extremely slow, the performance on the web pages is terrible and all the features that use hardware acceleration (like WebGL) are unavailable, because ALL the browser is software-accelerated.

  • What kind of graphics chipset are you running? Whats the driver version number?

  • Intel Express Chipset Family,
    Driver version: 8.15.10.1930.

    I don't think this problem comes from the driver version (because it's updated), everything was working before the update to Opera 28, Chrome and other Blink-based browsers aren't affected, only Opera (v28 and v29 Dev).

    Additional Information:

    OS: Windows 7 Home Premium SP1 (x86).
    Aero Glass: Enabled.
    There are no new updates for the driver.

  • WElp, I'd try a reinstall just to see if its something borked in the configuration files somewhere but other than that I got nothing. Make sure you really wipe it. Uninstall, restart, find the old folders and make sure they are deleted (see about page for their locations) and then install from scratch.

  • Hi @joegd21, go to the address bar, and type opera:flags#ignore-gpu-blacklist, press Enter, and click "Enable" button, restart the Opera, and see if this helps 😉

  • Thanks for your replies, guys.

    @Lando242, I did a clean install, but that didn't work. I checked the option ''Delete my Opera user data'' in the uninstaller and went to the profile directory to make sure the folder was deleted (and yes, it was).

    @L33t4opera, I already have that flag enabled. It was working before the update, now it has no effect.

    My guess is that something is preventing the GPU process to be launched on Opera's startup. As I said: only Opera 28 and 29 are affected (for now), so I assume that it's some kind of unidentified bug inside the browser's code. That would explain why the flag doesn't work and why the GPU process is not listed under the task manager.

  • Today is 10/16/2015. The problem hasn't been solved yet. The browser's GPU process is not working since version 28 and it seems there's no solution for this. Chrome is the only Chromium-based browser in which hardware acceleration is working for me.

  • Did you try to delete Operas GPU cache?

  • I've cleared all browsing data (History, Cache, Cookies...) several times and that hasn't solved the problem. Something is preventing the GPU process from booting during the startup. I'd be happy if I could find a workaround.

  • I had the same problem with Intel GMA 3150 (Windows 7 Ultimate, 32-bit). What is even worse is that Opera is not using the proprietary system codecs (like H.264 and MP3) if the GPU process is not running. I managed to find a workaround, though. According to opera:gpu the troublemaker is the EGL.
    Copy "d3dcompiler_46.dll", "libEGL.dll" and "libGLESv2.dll" from the installation folder of v27 to the installation folder of the newer version ("libEGL.dll" and "libGLESv2.dll" will prompt for overwrite so rename them). Instead of copying "d3dcompiler_46.dll" from v27 you can also rename the newer version's "d3dcompiler_47.dll" to "d3dcompiler_46.dll".
    I'm using v31.0.1889.99 and this enables hardware acceleration for me. No unexpected behaviour or crashes. I hope it will work for you as well, joegd21. 🙂

  • Thanks! It worked (partially). Most of the features listed are hardware accelerated now, but for some reason, WebGL isn't working :awww: . However, I used the same method with Chrome (which had been having the same problem since the update to v46) and it worked flawlessly. Now I know where the problem comes from . 🙂

  • You are welcome! 🙂
    WebGL has never worked for me, neither in v27 nor in any other version I have tried. Did it for you? I saw Intel GMA 3150 is blacklisted:
    Intel Graphics Media Accelerator 3150 causes the GPU process to hang running WebGL: 305431
    Disabled Features: webgl

    and enabling "Override software rendering list" didn't help. I didn't bother anymore, because it wasn't crucial for me. Now that you said, I tried Chrome, it states the same thing as above, but WebGL works, which is strange. I'll investigate further. Does opera:gpu state anything considering the Express chipset?

  • Nothing regarding the Express Chipset. It says something about the driver version, but it's not related to WebGL.
    Here's what it says: ''Accelerated video decode interferes with GPU sandbox on older Intel drivers''.

    There are no new updates for the driver and I don't care about the hardware-accelerated video decode, but it seems that WebGL is supposed to work for me and it isn't. BTW, I'm still experiencing problems with proprietary media codecs.

  • Hm, that's strange. What I have found so far is that (in my case) Chrome is using SwiftShader for GL rendering. I think it's falling back to it if there is a problem with the ANGLE renderer (those DLLs we moved). SwiftShader is completely software based, that's why WebGL is working for me in Chrome. If I rename the folder (C:\Users\*\AppData\Local\Google\Chrome\User Data\SwiftShader) so Chrome can't use it, ANGLE is used and I get the same situation as in Opera. I used it with Opera, but unfortunately the whole browser is laggy, glitchy and there is this huge SwiftShader watermark. WebGL works, though. I was almost sure it was the Intel GPUs, but you say yours is not blacklisted...
    Anyway, what's with the codecs? They generally do not work or just some specific files you've came across?

  • Anyway, what's with the codecs? They generally do not work or just some specific files you've came across?

    They just won't work, no matter the page I visit. Wherever there's an embedded mp3 or h.264 file, I cannot play it. I've already created a thread about it, but I could't find a solution.

  • but it seems that WebGL is supposed to work for me

    Hi @joegd21, you can try to add the --disable-gpu-sandbox switch at the end of the shortcut to the launcher.exe, as follows: "path\to\the\launcher.exe" --disable-gpu-sandbox, and see if this helps 😉

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.