Problem with https://web.whatsapp.com/

  • Hi,

    regarding the new feature of Whatsapp, using it via browser: https://web.whatsapp.com/

    Lately I have to use Chrome to open that page, it do not display in latest version of Opera Developer (Windows) any more.
    Only this appears:

    And I do not know what I have changed in the Opera settings or similar. And there are now javascript errors in the console, and so on.

    Any ideas?
    Thanks!
    mtemp

  • Did you try in Private Window (without any extensions)? have you some externing filtering oder adblock software?

    Opens fine on Opera DEV 28.0.1750.11 on Windows x64.

  • it works fine in stable 27.

  • I worked with all my various extensions -- but from one to the other day the page keeps nearly blank...

    I tried private modus: no effect
    I disabled all extsensions: no effect.

    ... but maybe there would be a new update of my developer version -- yes!
    28.0.1750.11 โ†’ 28.0.1750.15
    http://blogs.opera.com/desktop/2015/02/opera-28-beta-bookmark-syncing/
    (By the way: "DNA-32951 O-Menu opens on releasing Alt key after executing Alt+Enter in address field" -- Finally!)

    Advantage: https://web.whatsapp.com/ works again! ๐Ÿ™‚
    Disadvantage: all deactived extension before are gone ๐Ÿ˜ž

    But now I reinstalled my disabled extensions in the step before.

    Or in short: Thank you! ๐Ÿ™‚

  • Hi there!

    Since yesterday I also have a problem with the web version of whatsapp.
    Some days ago everything worked really fine.

    Then I updated to Opera 29 (version 29.0.1785.0), but it still doesn't work.

    Does anyone have any suggestions?!

    Thank you in advance!
    Chipy

  • ... now I have the same problem. It do not work with the latest version of Opera Developer โ€” installed yesterday, too...

    Opera beta 28.0

    Zum Entdecken gemacht

    Versionsinformation

    Version: 28.0.1750.31 - Opera ist auf dem neuesten Stand
    Update-Stream: beta
    Betriebssystem: Windows 7 64-bit (WoW64)

    screenshot

  • Hi @mkrasnov, @segros: this looks like the browser detection problem (sniffing). You can change the user agent to Chrome, or Firefox, and see if this helps. If you want, then for that purpose you can use the "User-Agent Switcher".

  • ... therefore Opera changed its user-agent identification from one developer version to the other? Hmm...

    And: are there no page specific options in Opera Next/Developer as it exists in Opera 12? (trying out another browser identificition only for https://web.whatsapp.com/)

    And an addition to my previous comment: I skipped @mkrasnov information that there is alread version 29 out (oh, since several days not only since yesterday...) โ€” I will give it a try, too ๐Ÿ™‚

  • Hi, I contacted their support today. It seems that their web app doesn't recognize the UA strings from beta and developer streams. Workaround: you can change it to the one from the final version of Opera, which is working properly.

    Thanks for reporting that, segros ๐Ÿ™‚

  • Hi there!

    I am glad, I am not the only one having troubles with the web.whatsapp.

    @l33t4opera: The "User-Agent Switcher" doesn't change the behaviour of Opera Developer.
    It doesn't even matter which "Browser" I choose. I tried several of them... ๐Ÿ˜ž

    All the time I am getting the error:
    "WhatsApp Web only works with Google Chrome 36+
    To start using WhatsApp Web, update Chrome or use Mozilla Firefox or Opera.
    UPDATE GOOGLE CHROME"

    @mmitek:
    Unfortunately, I don't understand your workaround.
    What exactly did you change and where?!
    And thank you for conacting the support!!!

    Thanks in advance!

  • What exactly did you change and where?!

    Using the "User-Agent Switcher", change Opera's own UA to remove the "(Edition developer/beta)" part.

  • Hmm, after submitting my solution (a combination of the hints above ;)) Opera show me https://forums.opera.com/moderation without content... (in the source code: ยป... TransportError' : "A fatal error occurred while processing the request.<br />The server returned the following response: %s" ...ยซ

    Now a shorter description of my workaroud:

    โ€” https://addons.opera.com/de/extensions/details/user-agent-switcher/?display=en
    โ€” creating a new entry with the default agent (see https://www.esolutions.se/whatsmyinfo) of (my) Opera 29.0.1785.0 just without the string ยป(Edition developer)ยซ. Result:

    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2298.0 Safari/537.36 OPR/29.0.1785.0

    โ€” Using this new entry/agent on https://web.whatsapp.com/ it works again!

    screenshot

  • ... and see this Twitter message: https://twitter.com/opera/status/571279416162160641

  • The workaround provided by segros works for me as well.

  • Using the "User-Agent Switcher", change Opera's own UA to remove the "(Edition developer/beta)" part.

    @leocg: is it possible to change Opera's agent without creating a new entry?

  • Using the "User-Agent Switcher", change Opera's own UA to remove the "(Edition developer/beta)" part.

    @leocg: is it possible to change Opera's agent without creating a new entry?

    Not sure, I'm not very familiar with the extension.
    Maybe if there is a way to edit the default one.

  • Hello,

    my solution:

    โ€” Installing this extension: https://addons.opera.com/de/extensions/details/user-agent-switcher/?display=en (mentioned above: thank you @l33t4opera :))
    โ€” In the predefined user-agents entries there is no an entry for the developer version (or Opera Next). There I created a new entry (based on the/my default user-agent of my Opera version 29.0.1785.0):

    The default one of this version (https://www.esolutions.se/whatsmyinfo๐Ÿ˜ž

        Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2298.0 Safari/537.36 OPR/29.0.1785.0 (Edition developer)
    

    As mentioned by @leocg I deleted the string "(Edition developer)" and saved it as an new entry e.g. with the label "myOperaAgent":
    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2298.0 Safari/537.36 OPR/29.0.1785.0

    โ€” Then I went to https://web.whatsapp.com/ and using the "new agent" WA works again! ๐Ÿ™‚

    But maybe we just have to wait few days and we can live without such a temporary solution...

    Alt text

  • You can start Operas launcher on commandline with the parameter --user-agent="..."
    (... should be the new Useragents string).

  • @segros:
    Thank you very much for your instructions!

    I followed them and web.whatsapp works again like a charm!!!
    Thank you!!!

    Is there an automatic possibility to turn the User-Agent Switcher just on, when you enter web.whatsapp, but to keep it off surfing on any other site?!

    Thanks in advance!

  • Hey there!

    Solved it with another User-Agent Switcher.
    The one I found is "User-Agent Switcher for Chrome" (https://chrome.google.com/webstore/detail/user-agent-switcher-for-c/djflhoibgkdhkhhcedjiklpkjnoahfmg).

    There you can define different agents for different pages...

    Good luck!
    Chipy

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.