Writing "-" zooms automatically

  • On some websites (e.g. Facebook or Opera Help) my "-" and "+" keys also work as zoom keys and this is driving me crazy. I would want "-" to zoom only when pressed together with the Ctrl key and not on its own.

  • +1 confirming the same behavior. "advanced keyboard shortcuts" are disabled.

  • There is a file in the Opera directory that you can edit to change the shortcuts. Please read thsi post for an example on how to do that.

    https://forums.opera.com/post/36754

  • Thank you but it does not really give me an idea as to how to instruct Opera to NOT DO anything when i press the "-" key (apart from writing a hyphen). In the Preferences file I could not find anything about the "-" key; the only key reference is
    {
    "Keybindings": {
    "Settings": {
    "AdvancedEnabled": false
    }

  • In the meantime, I just wanted to comment on a Facebook post with a "+" sign in my comment and of course it also zoomed. Grrr.

  • Thats interesting. When I have a text box active - and + only type, not zoom. Or is this some keyboard shortcut built into Facebook? I don't use the site so I wouldn't know otherwise.

  • I just want to zoom ONLY with Ctrl- and Ctrl+ and not with - and +, pages and text boxes notwithstanding.

  • I can confirm that I have only seen this on Facebook. Textboxes on Youtube, Tweetdeck, other forum software and what other few pages I can quickly check all work just fine. Including this forum.

    • The ",", "." and "/" keys pull up the in-page search.
    • 6, 7, 8 change the zoom.
    • "z" tries to go back a page.
    • probably all of Opera's keyboard shortcuts are affected (I have "Advanced Keyboard Shortcuts" enabled).

    Whatever JS Facebook is running is making Opera think the cursor is not in a textbox.

    If it isn't already, this should be a Priority 1 "Site Unusable" bug. And it's out here because of your damn auto-update.

  • "Whatever JS Facebook is running is making Opera think the cursor is not in a textbox."

    That is the point. And the issue is there even if "Advanced Keyboard Shortcuts" are not enabled but then it is just the "-" and "+" keys.

  • I filed a bug report.

  • I just went to Facebook, clicked in the textbox to update my status. The "-" and the "+" keys did not zoom but did print the symbol into the textbox as expected. I am on Opera 27 with Advanced Keyboard Shortcuts enabled.

  • It's DNA-32278.

  • I just went to Facebook, clicked in the textbox to update my status. The "-" and the "+" keys did not zoom but did print the symbol into the textbox as expected. I am on Opera 27 with Advanced Keyboard Shortcuts enabled.

    8sheldon8: Try the comment box under a post.

  • I have exactly the same - try to put Z into a comment..... NO WAY 😕

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.