Google search always uses thai google (google.co.th)

  • Hello,
    I had lived in Thailand for some time and somehow I switched to use thai google by default - i.e. when I write a search query in the url text box or in the search text box on the speed dial screen, Opera uses thai google (google.co.th). I don't live in Thailand anymore and would like google.com to be used instead. But I can't find how/where I can change it. I tried to reinstall the browser, tried to search and delete for "google.co.th" or "th" in different opera settings files and many other things, but with no result.
    Please help.

  • There is a locale string in Opera's settings files, it must not have updated it since. Go to menu > About Opera to see where it lits your Profile path as. Open that path in a file manager window (some of the folders are hidden by default, it will be easiest to paste the path into the Location bar and hit Enter) and find the file Local State. Despite the lack of an extension, it is a text file and can be edited in any text editor - even Notepad.

    You will see a section named Location. Mine looks as follows - obviously yours will indicate Thailand:

    "location": {  
       "country": "us",  
       "country_from_server": "US",  
       "timestamp": "1413940012600000000"  
    },  
    

    You can either delete the whole section (while Opera is closed) and let Opera recreate it for you new locale, or you can edit it by hand.

  • Thank you very much, sgunhouse!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.