Clicking email links opens Opera 26 but I want Opera 12.17 as default - how do I change it?

  • Every time I click a link in an email it starts up Opera 26, even though I have Opera 12.17 already open. I've looked all over in both browser settings and in Outlook Express settings but can't find an option to change this. Can anyone help please?

  • You have to install Opera 12 systemwide for all users and set Opera 12 as default browser in your Windows Progrms and Computerstandard.

  • Which one is your default browser? You may need to change that.

  • I have always had Opera 12 as my default browser, including in Windows settings, and it is only since installing Opera 26 that this is happening.

  • It keeps happening even if you reset Opera 12 as your default browser?

    Check if it is set to be the handler for http protocol and html files.

  • I'm not sure how to check for that but I have been fiddling with the settings in Windows and have just clicked another link in an email to test it and, once again, Opera 26 started up and even asked if I wanted it to be the default browser! So why is it the default browser when it thinks it isn't!

    I'm closing my computer now but tomorrow I will see if closing the browsers down and restarting Windows will have any effect.

  • Download the Opera 12.17 installer, launch it, click "options", set "install path" to your existing Opera 12.17 install directory, set "install for" to "all users" and check "Use Opera as my default browser" and click "upgrade".

    That should fix things. But, for good measure, go into "default programs" in Windows and make sure Opera 12.17 has anything. And, go into "Alt + p -> advanced -> programs" in Opera 12.17 and make sure it's set to check for defaults. Also, click "details" there and if it doesn't load "default programs" in windows and has a bunch of checkboxes for file types and protocols instead, make sure http and https are checked and click ok.

    Another thing you might have to do is you want both Opera 12 and Opera 26 open is open Opera 12 after you open Opera 26. But, hopefully you won't have to do that.

    Short of the above, you'll probably have to edit the registry to make sure all the opera.exe paths for Opera 12.17 are correct and make sure http and https are set to use Opera 12.17.

    But, Opera 26 might just be greedy for some reason.

  • ...And, go into "Alt + p -> advanced -> programs" in Opera 12.17 and make sure it's set to check for defaults. Also, click "details" there and if it doesn't load "default programs" in windows and has a bunch of checkboxes for file types and protocols instead, make sure http and https are checked and click ok.

    Switching on this morning still didn't solve the problem but Burnout's suggestion above did work without reinstalling everything.

    Thank you very much!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.