Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Email is blank / how do I re-download an imap mail?

  • Hi,

    First time user to Opera Mail and assessing it as a possible replacement for Thunderbird. I'm having behaviour where some of my email is showing as blank. This seems so obviously wrong wrong and something that would get picked up in QA that I'm wondering if I've misconfigured it somehow?

    Images are below.

    What I see in Opera:,N3Jquxy,ez3fSXy,CbtcS77#0 - Apologies for the heavy redaction). However please note that the white pane on the far right (where the email content normally is) is NOT redacted - it is just blank.

    What I see in Thunderbird:,N3Jquxy,ez3fSXy,CbtcS77#1

    What I see in my webmail client (roundcube):,N3Jquxy,ez3fSXy,CbtcS77#2

    What I see when I right-click and select "View All Headers and Message":,N3Jquxy,ez3fSXy,CbtcS77#3

    I'm guessing based on the last one that the email has not downloaded correctly. Is there a way to re-download it? I've tried hitting 'Download Complete Message' but this does not appear to have done anything.

    Actually, from memory I might have experienced this problem in the past Thunderbird as well, but it was fixed by restarting it (which did not help for Opera)

    Opera Mail 1.0 build 1040 Win32
    Platform: Windows 7 64-bit SP1

  • Please check:

  • It indeed looks like the message body for the message didn't download.

    It does indeed sound like your mail folder is messed up and the stuff in the link will fix it. But, there are a couple of things you can try first.

    If this is not happening in your IMAP "INBOX" folder, you can goto "Menu -> mail -> IMAP folders", unsubscribe from folder and resubscribe.

    You could instead delete the IMAP account and add it back in.

    If you just want to fix a few messages, you could use your webmail to copy the messages to another folder. Then, you could delete the originals and move the copies back.

    Also, avoid using "do not download attachments" or "low-bandwidth mode" as those have downsides to syncing message bodies. Also, check on the "Incoming" tab in the account's properties and make sure you set the availability of messages offline to what you want.

    But, just doing what's in the link will ensure that everything is right.

    Regardless of what you do though, close down Opera Mail and edit incominN.txt in the mail folder (where N is the number for the account as seen in accounts.ini. You can goto "Menu -> Help -> about Opera Mail" for the location of the mail folder. Anyway, in incomingN.txt, you'll want to make sure Disable QRESYNC=1 is set to avoid synchronization problems. And, *if* you have to, set Force Single Connection to 1.