Opera Mail: Settings not being saved

  • Opera: 26.0
    Opera Mail Version: 1.0
    Build: 1033
    Platform: Win32
    System: Windows 7

    Here's my problem: In Opera Mail, I set my preferences in different fields, but they never get saved. For example:

    1. Under Opera Mail > Settings > Preferences > Advanced > Notifications:
      For the box "Show notifications for new messages", I de-select the option and click "OK". It doesn't get saved, because every time I open the preferences, the box shows that it's still selected (as the default option).
    2. Under Opera Mail > Settings > Preferences > Advanced > Fonts:
      I choose my font and click "OK", but it never gets saved. Always goes back to the default font.
    3. I choose to hide Mailing Lists, but every once in a while, they still keeping showing up.
    4. Every time I compose a new message or respond, I have to keep selecting "Use HTML formatting". Can't this be set as a saved setting?

    Any suggestions or help would be greatly appreciated. Thanks!

  • Old known issues. If you add the lines directly in the operaprefs.ini file, it should work.

  • Thanks for the reply, leocg.

    I'm not sure what you mean, though. Have no coding experience. Help?

  • You need to close down Opera Mail and edit operaprefs.ini in the preferences folder (see help -> about Opera Mail for the location).

    Under [User Prefs], set:

    Show Notification For New Messages=0
    

    You need to add the line if it's not there or if it is there, change it from 1 to 0. If you want it turned on again, you can either set it to 1 or remove the line to make Opera use the default for the setting, which is 1.

    For the "Use HTML formatting" option, that's on the outgoing tab in the account's properties. That setting should save just fine. But, if it doesn't, you'll need to close down Opera Mail and edit accounts.ini in the mail folder. Under the section for the account in question, change the "Prefer HTML Composing" setting to 1. Make sure accounts.ini isn't set to read only.

    For the fonts, you'll have to edit operaprefs.ini for those. Download Opera 12.17, launch the installer, click "options", set "install path" to a folder on your desktop and set "install for" to "Standalone Installation (USB)" and install. Then, load up that Opera, change the fonts and close it. Then, in that folder on your desktop, look for operaprefs.ini in the "profile" folder. In it, you'll see the font settings. You'll then have to duplicate those settings in your Opera Mail operaprefs.ini.

    For the mailing lists, if you're talking about the "Mailing Lists" access point in the mail panel, that will reappear every time you get a new mailing list message. Instead of hiding it, right-click in that section, create a new folder named "hide" and drag all your mailing lists into it. Then, collapse that "hide" folder. so the mailing lists access point doesn't take up much space.

  • With Opera Mail closed, open operaprefs.ini in a text editor and add/change the lines:

    [User Prefs]
    Show Notification For New Messages=0
    

    About 3, it will appear everytime a new mailing list is "created". Maybe you are receiving some messages that make Opera believes that they are part of a mailing list.

    About 4, add/change this line to accounts.ini:

    [AccountX]
    Prefer HTML Composing=1
    

    X is the number of the account in accounts.ini.

    Note that it only works for new messages and messages received in html. If replying to a text based message, this format will be used.

  • burnout426 and leocg, thanks so much! What a great, supportive community here.

    Cheers!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.