:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Opera 12 -- increasing font size in Source viewer ?

  • I'm using Opera v. 12.x on older systems, Win7 and OSX.6.8, Snow Leopard, and like their stability and features. Making great use of the Source viewer/editor to keep customized versions of web pages locally -- can edit the html, instantly view my changes in another tab, even Save the edited code to local directory.

    The BIG PROBLEM is that the font in the Source viewer/editor is incredibly small and can't be enlarged by control-(+) or enabling a User .css as far as I can see. Nor can I find a preferences file to change this. Any advice ?

  • The viewer for the source is set under Tools>Preference Settings>Advanced>Programs.
    On Windows the default is Notepad, and presumably on Mac whatever the Notepad equivalent is.
    You can change that to another text viewing program that will allow you to change the font size.
    It's nothing to do with Opera.
    :)

  • Thanks DaveH, but you're talking about using an external editor. Both Mac and Win (on v. 12 and many versions before) have a built-in Source editor invoked on Win7 by following Opera/Page/Developer Tools/Source and on OSX with View/Developer Tools/Source -- much handier than using the external editor, for reasons listed above -- you don't have to switch back and forth between applications. The native Opera source editor is the one I'm trying to configure.

    am

  • Is that the same as pressing Ctrl+F3?
    That is what selecting Tools>Advanced>Developer Tools>Source does on my system (Windows XP) and it opens the source in Notepad.
    :confused:

  • Go to 'O-Menu / Settings / Preferences... / Advanced (Tab) / Fonts (Left hand list)' and in the main part of the Preferences window, change the 'Email compose' font to the size you need.

    Or if you have the standard menu bar enable in Opera:

    Go to 'Tools / Preferences... / Advanced (Tab) / Fonts (Left hand list)' and in the main part of the Preferences window, change the 'Email compose' font to the size you need.

    Or just press CTRL + F12 and go to 'Advanced (Tab) / Fonts (Left hand list)' and in the main part of the Preferences window, change the 'Email compose' font to the size you need.

  • Dave says: "... and it opens the source in Notepad..." -- I suspect because you used the Preferences option to select this app for viewing Source. When freshly installed, Opera's default is to use 'Opera' for this.

    linuxmint7 suggests: " change the 'Email compose' font to the size you need." -- this works great in Windows 7, and is some help, thanks.

    Unfortunately, I do almost all this stuff on Mac OSX ! Tried resetting all the email options, compose, view, compose HTML -- no joy. Maybe on the Mac I will enable the external editor, and deal with the small added hassle of switching apps. Will also try asking in the Mac section of forum.

  • Ah, right. I don't remember manually changing the program to Notepad, but I guess I must have done back in the mists of time!
    Changed it to open with Opera, and the font size does seem to be OK for me.
    :)

  • He did say it worked in Windows, but not on his other Mac computer ...

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.