Opera 19 causing issue with IP location detection?? or site compatibility? ->BBC iplayer in UK

  • Hi,

    I've got a slightly odd issue with Opera 19. The BBC iplayer site no longer recognises that I am in the UK. I got a new IP from my ISP about a week and a half ago and I thought it might be a network issue associated with that. However I noticed yesterday that it is working OK in Opera 12.16 and Firefox. Example link which gives me this error:
    http://www.bbc.co.uk/iplayer/episode/b03sltyb/hd/Sound_City/

    Any suggestions on how to troubleshoot this further?

    Thanks in advance.

  • Works OK for me in Opera 19 from the UK. Try clearing your cookies.

  • Originally posted by Pesala:

    Works OK for me in Opera 19 from the UK. Try clearing your cookies.

    Hi Pesala,

    Thanks for the suggestion, should have thought of that myself. Though funnily enough I'm having trouble getting my cookies to delete.. I'm using the "Clear browsing data.." button under the Privacy Settings with all the boxes ticked. However, even if I close all tabs, do that, and then restart Opera I'm still logged into this forum so I'm not convinced it's working properly. Is there something else I need to do? It hasn't changed the issue with iplayer.

    I don't know if it's useful as I'm not a developer but the web inspector gives the following 11 errors and 1 warning:

    GET http://static.bbci.co.uk/bbcdotcom/0.3.221/style/3pt_ads.css  (index):242
    GET http://www.googletagservices.com/tag/js/gpt.js  bbccom.js:1
    Uncaught ReferenceError: DM_tag is not defined (index):892
    GET http://js.revsci.net/gateway/gw.js?csid=J08781  (index):885
    Uncaught ReferenceError: COMSCORE is not defined (index):926
    GET http://b.scorecardresearch.com/beacon.js  (index):919
    GET http://me-cdn.effectivemeasure.net/em.js  (index):1017
    GET http://static.bbci.co.uk/bbcdotcom/0.3.221/script/vendor/gemius/xgemius.js  (index):1058
    GET http://survey.112.2o7.net/survey/dynamic/suites/133/bbcwglobalprod/list.js?685866695089  VM368:3
    GET http://sa.bbc.co.uk/bbc/bbc/s?name=iplayer.episode.sound_city.b03sltyb.page…ns_referrer=http%3A//www.bbc.co.uk/iplayer/episode/b03sltyb/hd/Sound_City/  (index):353
    GET http://stats.bbc.co.uk/setbguid  core.js:19
    event.returnValue is deprecated. Please use the standard event.preventDefault() instead. jquery-1.9.1.js:14
    

    Also, I should note that I did try disabling my addons yesterday with no change.

  • Scroll down a bit further in Settings to find the Cookies manager.

    I am also not a web developer, so the code means nothing to me. I am just guessing what to try based on long experience of what fixed previous problems.

  • Originally posted by Pesala:

    Scroll down a bit further in Settings to find the Cookies manager.

    Thanks Pesala. I used the "Remove all" button under the "All cookies and site data..." button and then refreshed the iplayer page. It gave the loading jam issue reported elsewhere on these forums which I have also experienced before. On second refresh it came up OK but still says I'm outside UK. So I closed the tab, deleted cookies again and restarted Opera before loading up the site again and it still shows the same issue.

    I guess it's not a simple cookie issue so. 😟

  • Are you using the off-road mode?

  • Originally posted by LeoCG:

    Are you using the off-road mode?

    Hi LeoCG. I didn't realise it but yes, I just noticed that it was ticked in my menu and switching it off has resolved the problem - thanks!

    ..What is off-road mode? Is it like the the old Opera Turbo? I certainly didn't knowingly enable it.

  • Originally posted by ishatix:

    Is it like the the old Opera Turbo?

    Yes.

  • Originally posted by LinuxMint7:

    Originally posted by ishatix:

    Is it like the the old Opera Turbo?

    Yes.

    OK, thanks for clarifying.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.