Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Cant see font after changing my theme on the os

  • 😕

    Thanks linuxmint7 but it didn't change what I needed it to. It changed something else. I'm sorry but I don't have screen shots to show so I'll do the best I can to describe the situation with words.
    Please help!

    --> I did some testing with and without the setting change...

    • Conditions of experiment:

    First tab ( On that web page there's a search field on the web page itself. The field is located at the top center of the web page and the fields visible within the entire o/s window for Opera is the google search field which is part of opera (located to the right of the url bar) and the search field that's on the the google web page.

    Second tab (Opera speed dial): Fields visible within the entire o/s window for Opera are the google search field which is part of opera (located to the right of the url bar) and an identical google search field (located in the top center of the speed dial page).

    Paste the bold text into the address bar 'opera:config#FileSelector|DialogToolkit' and press enter/return, then change its setting to '3' and click the 'Save' button just below.

    You may have to restart Opera for the changes to take effect.

    • With prescribed change to setting in opera:

    Background of the field on the google search page changes to match my theme (black in color) but the font color within it does not change (font in that field is black). Nothing changes within the other google search fields (to the right of the url bar and top center on the speed dial page). These, latter fields, are (white background with very very light blue font).

    • Without prescribed change to setting in opera (ie: back to default on that change):

    Background of the field on the google search page is white and the font is black. Nothing changes within the other google search fields (to the right of the url bar and top center on the speed dial page). These, latter fields, are (white background with very very light blue font).

    • Current condition:

    I have gone back to opera:config#FileSelector|DialogToolkit, clicked the button marked 'default', and restarted Opera.

    • Problem description:

    Font color in problem fields is too light to see...

    I'm comfortable with the default setting for opera:config#FileSelector|DialogToolkit (white background with black font in the google web page field). I would like to get the other fields (to right of url bar, top center of speed dial page, and fields like this I'm typing in) to match. (ie: for them to have a white background with black font).

    • Additional Comments:

    This comment text box that I'm typing in now is white background with the very light blue font - I've been using ctrl+a to highlight the text periodically so I can see what's here. I would like these field types to also be white with black font.

    The light blue font color in this box I'm typing in is only that way whilst I'm typing into it. After the comment is submitted the font color changes to black.

    The font color in your post (and other submitted posts) is black.

    • Needed:

    Change font color for problem fields to black, but keep the setting opera:config#FileSelector|DialogToolkit as default.

    Thanks in advance for any help you can provide. It's difficult to get anything done with things as they are now.


  • I could not really follow your scenario descriptions fully, as not seeing them for my own eyes made it difficult to picture.

    Have you tried changing that setting to 1, 2 or 4 ?, obviously saving and restarting Opera in-between each change.

  • Thanks linuxmint7. Sorry for the lengthy description. I did the best I could...

    The problem isn't in the web pages that load or their fields, it's in the native fields within opera. I'm noticing more now and the problem lies in Opera's url bar, Opera's google search box(s) and even some of the fields in Tools > Settings (the ones that have a white background). And, I don't know why, but this text box I'm typing into now as well. (I would think 'this' text box would be considered part of a web page and not native to Opera). I tried looking at fonts in 'opera:config#Fonts|DialogToolkit' and tried ticking the box 'Prefer fontconfig settings' and restart but to no avail. I also was not able to change any actual font colors within that setting section. Going to go back and untick that box to revert back to default again until a soln can be found.

    Do you know what to do to change the font color in these Opera native fields where the background is white?


  • I'm sorry, I see it's not that I couldn't change font colors in 'opera:config#Fonts|DialogToolkit', it's that I don't quite understand that method of making changes (ie: the syntax). For instance, the field labeled 'Form Input' has the setting '12,4,0,0,0,0,Ubuntu'. Also, I'm totally guessing as to what each field in that section is for - I'm only guessing that 'Form Input' would correspond to anything I'm actually having a problem with and not something unrelated.

  • What I need is for Opera to remain independent of the theme that I installed. It was fine before that and I'm not gonna suffer without a them bc of it, I love opera and would grieve it's loss if I had to try other browsers to see if they are usable 'with' a theme installed.

  • Oh, I'm on Ubuntu (14.04 with unity) btw - not arch

  • Wow, this is totally awesome. The one guy who tries to help get's it wrong and then abandons me. I suppose next someone will suggest that the soln is to not have themes on my computer ( as apposed to fixing the real issue by finding/changing settings in opera ). No, I couldn't be so lucky --> apparently I'll just flat out get ignored for who knows how long - maybe forever. And I was liking opera. This is gonna really suck.

  • Wow, this is totally awesome. The one guy who tries to help get's it wrong and then abandons me.

    Thanks for the much needed complement, but you need not have extended your gratitude thus far. One thing you may not know, but maybe very useful, is that this is mainly a user to user forum and most people here offering help do not work for Opera, but do it voluntary and have lives outside of this forum. Just something to think about.

    Anyway, what was your reason for not being able to post an image to show the problem that you are going through ?.

    There should be a utility/program in Ubuntu to take a screen shot of your desktop/program window.

    If you have nowhere to host/upload the image, you can use an image hosting site ( for example) and post the link to said image in one of your posts here.

  • I'm so very sorry. This is one of the most frustrating things I've had to deal with (I use the internet a lot). I do appreciate your help linuxmint7. I'll try to display the problem with screenshots but I'm not sure how to do that since the problem involves what you can't see (the letters beingtyped).

    The only thing I can think to do is take screenshots in pairs where one is with text selection (to make it appear highlighted and see the font at all) and the othe without the text selected (so you can see the problem). By the way, the green highlighting is from the theme. From what I can tell it's a popular theme that's been around for a while, mature, and widely used (from what I can tell).

    Link to theme: (for reference purposes regarding my issue):

    Link to screenshots:

    --> Notables:

    Imgur seems to have destroyed the original file names I so painstakingly named to show the grouping of the photos and what they represent. I'm sure you'll get it when you browse them though. The seccond bullet point (directly below) uses references from those original file names. Sorry about the mishap.

    -- Format of file names is < group number > < subgroup letter > < second level subgroup number (when present) >

    -- Notice the difference between Screenshots 2b1 and 2b2. What's happening here is that 2b1 is the way it shows up when the page is first loaded and 2b2 is how it shows after the text is selected then unselected. In 2b1 only the domain is very light and not visible, but the rest (after the first / ) is dark enough to see. In 2b2 (after selecting then unselecting the text) the entire string becomes very light and not visible.

    -- The extra screenshot showing google's search page shows that the font is fine in it's search box.

    -- The extra screenshto showing wikipedia's page shows that the font is fine in it's search box (upper right corner of web page).

    -- Even when on google or wikipedia's search page (and other web sites I'm sure) - the problem areas shown in screenshots 4a and 4b remain the same as shown in those screenshots (ie: screenshots 4a and 4b).

    Again, thanks linuxmint7 for your help. I'm sorry my frustration got took out here. This is a tremendously frustrating situation.


  • Ok clientalive, I've just installed and selected the theme you linked to in your last post from Deviantart (I'm running Linux Mint 17 with MATE desktop) and set the option in Opera that I suggested in my first reply to you back to default (which is '0'). I restarted my machine and started up Opera, low and behold I was suffering the same problems you were, such as feint fonts in the address bar and text areas here on this forum (for example), as shown in your screen shots.

    From what I can gather, when reading back on one of your previous post above, I think there may have been some confusion and you may have selected and changed the wrong option.

    Copy and paste the text below into the address bar and press enter/return.


    This IS the option you need to change to sort your problem out (as I first suggested above), and you need to change it from '0' (zero) to '3' (three), by either typing the number into the box to the right of the option or by using the up and down arrows. Then click the save button just below the option and restart Opera.

    Screen shot of the above option.


  • Yay! it works, but with selection 4 (for this system). Don't ask me why but use x11 file selector did it. linuxmint7 I'm sorry I didn't try that one sooner (I had tried 1, 2, and 3 before but now 4). I remember kinda cringing when I thought about trying x11 for it before (seemed, err... sketchy). Anyhow. Thank you so much. I've got my Opera back! :>

  • Great!!! 🙂

  • I just upgraded to Opera 27 - problem solved.

  • Hello
    I have that same problem with Opera 41.0.2353.69.

    When I use opera:config#FileSelector|DialogToolkit in adress bar Im only moved to settings tab.

    Do you have any suggestions?

    My OS is Win 8.1, but problem is the same as your. Also in Opera Developer.

  • The opera:config URL was for Opera 12.x or older ...

  • Is any way to change that setting in Opera 41? Any ideas?

  • That setting would have no effect in Windows anyway; you really need to repost in the correct forum here.