help

  • Hi, im using micromax bolt a26,Android:2.3.5. The problem is that im not able to install opera mobile browser after the version 16.0.1212.6378. I tried to go to google play for the latest version ie version 18 but stil gopgle play says that my device is not compatible. I downloaded the .apk file from the opera website but still when i click the installation file it tells that there is a problem in pharsing the file.why is this happening?plz help

  • Try Opera Beta instead - Opera had some restrictions not present in the Beta.

  • Both Opera for Smartphones final and beta branch are now limited to 4.0+ devices.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.