5 minutes to Launch, 10 process and no current task or window

  • Launching Opera is taking more and more time. Recently I waited for like 5 minutes and the browser still did not launch so I thought I would check the task manager. What I found was this:
    https://www.dropbox.com/s/v1kfs49bv496gp3/Screenshot 2014-11-02 15.54.01.png?dl=0

    There were 10 Opera processes although the last opera window I used was closed like 30 minutes ago. For some reason, Opera seems to not be closing properly. I have never used any kind of forced closure before; just the [X] close button.

    These are my opera system stats:
    Version: 25.0.1614.68 - Opera is up to date
    Update stream: Stable
    System: Windows 7 64-bit (WoW64)

    Anyone having a similar problem?

  • Yes/I have this problem
    10 process
    600 mb
    200 mb
    95
    95
    86...

  • Do you use any extensions? If so, try disabling them and see if Opera closes correctly now.

  • Open up the task managed built into Opera and have a look at whats running. It should have an entry in its task managed corresponding to every entry in the Windows task manager but with more info. You will find it in the O menu in the Developer Tools sub-menu, if you have that enabled.

  • Yes/I have this problem
    10 process
    600 mb
    200 mb
    95
    95
    86...

    That is not a problem, it is the way Opera works now. Every tab, extension and plugin havĂȘ their own processo.

  • Thanks for your reply all. I was able to inspect the opera task manager after enabling the dev tools. So far things are normal, will have to wait until I notice unterminated processes to inspect.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.