Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to remove the tiny 1 pixel space above the tab bar.

  • Again - that option does not fix the problem for me. It visually switches between a tiny space and what appears to be no space, but the tabs are non-responsive (and don't highlight when hovered) if the mouse is at the very top of the screen in either case.

    The only other program I have installed with tabs at the top like that is firefox, which does not exhibit this behavior.

  • I reverted to Opera 22.0, and it's working again for me. I guess I'll stay on this version for a while.

  • Still works in Opera 25.

    Settings, Show Advanced Settings: Disable tab bar's top spacing when browser window is maximised

  • Just tried a clean install of Opera 25 (removed all other versions first), and it's still giving the broken behavior. The "Disable tab bar's top spacing when browser window is maximised" option toggles between a visual space and no (or super tiny) visual space, but neither On nor Off results in being able to click at the top of the screen.

    Going to revert to a previous version again.

  • any solutions?

  • Working fine here. Are you still using version 25?

  • I just installed so I have the newest stable version - 27.0.1689.66

  • Welp, like I said its working fine here. What version of Windows are you using?

  • win 7

  • Hi there,
    I'm pretty sure the "Disable tab bar's top spacing when browser window is maximised" in the "Advanced Settings" only works with Windows 7, and not with Windows 8 (I'm using Win 7 on my desktop and Win 8 on my laptop, that's how I found out).

    It's a terrible, terrible oversight which makes Opera on Windows 8 near useless for me.

  • I'm using Windows 8.1 and it works fine for me.

  • only works with Windows 7, and not with Windows 8

    Only if they have changed something regarding this because it used to work when i was using Win8 and it works on Win10.

  • Hello,

    Windows 10 latest version (Nov 2015)

    Opera 33

    Doesn't work 😞

    I see the pixel disappear, but nothing happens when I click the top of the screen, has to be a bit lower

    Very annoying!

    Opera people, please fix it!

  • Windows 10 latest version (Nov 2015)
    Opera 33
    Doesn't work
    I see the pixel disappear, but nothing happens when I click the top of the screen, has to be a bit lower

    It seems to be working here, it changes to the tab when i click there.

    Btw, are you using Opera maximised? It will only works with Opera maximised.

  • Hello,
    Windows 10 latest version (Nov 2015)
    Opera 33
    Doesn't work
    I see the pixel disappear, but nothing happens when I click the top of the screen, has to be a bit lower
    Very annoying!
    Opera people, please fix it!

    works fine here

    win10 x64, latest stable (and all other channels)

  • By maximising, you just mean the regular button on the left of the "close" one?

    I'm in 4K, could this be the reason?

  • Doesnt work here too on latest dev. Same behavior as fred1976 and meeotch666 experienced. Option switches pixel, but tabs are not clickable. Win 8.1/64bit + 1080p + 125% dpi scaling. Works fine with any other browser. Something is definitely broken.

  • Hi, I think I found out why some users (including myself) aren't able to click on the tabs because of the 1pixel space even when the option "Disable tab bar's top spacing" is checked.

    It's because I've set "Set custom text size (DPI)" of 110% in: Control panel -> Appearance & personalization -> Display -> Set custom text size (DPI) -> 110%

    When I switch the text size back to: Smaller - 100% (default) I can click on the tabs in Opera 38 even when the mouse is at the topmost point on the screen.

    I'm on Windows 7 and using the latest Opera 38.

    Do you think this can be fixed?

  • You can run Opera at 96dpi (100% text size), using next command-line option, maybe this fixes problem for you:

    --alt-high-dpi-setting=96

    Otherwise you could file bug report.

  • Thanks! This fixed the issue!