Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera is not detecting the PPAPI Flash Plugin.

  • Hi, I just installed the latest build of PPAPI Flash plugin (beta) because I heard it has some benefits, however, Opera is not detecting it, only the NPAPI one. The flag ''Find Pepper Flash Plug-in'' is enabled (by default). I disabled and then uninstalled the NPAPI Flash, restarted Opera, cleared all browsing data, etc. None of that worked.

    I tested in the following Opera versions:
    Opera Stable 24.0.1558.61
    Opera Beta 25.0.1614.11
    Opera Developer 25.0.1614.5

    My operating system:
    Windows 7, SP1.

  • If you uninstall both npapi and ppapi flash players and then install the ppapi one, does opera detects it?

  • Nope.

  • So there is no flash listed under opera:plugins after you've tried it?

    That's strange. Here - I'm on Win8.1 - all Opera installs (Stable, Beta and Developer) have ppapi flash listed under opera:plugins.
    Maybe it's a OS issue? I have Win7 on another computer, i'll try to check later.

  • So there is no flash listed under opera:plugins after you've tried it?

    No, and I remember that Opera was capable to find the Pepper Flash when I tested the flag for the first time (in Opera Developer 23, I think).

    I have Win7 on another computer, i'll try to check later.

    Sounds like a good idea, let me know if it works there.

  • I've just tested here on Win7 with Opera Stable 24.0.1558.61 and everything worked fine, ppapi flash is listed under opera:plugins.

    I downloaded and installed Flash Player for Opera and Chromium based applications – PPAPI just in case.

  • I downloaded and installed Flash Player for Opera and Chromium based applications – PPAPI just in case.

    That's the one I installed...

    @leocg, on which directory Flash Player is installed? Maybe my installation was not successful... Although my Opera has been malfunctioning. I mean: WebGL support is gone, and now this. I don't know if it has something to do, but I use Windows 7 32-bit.

  • opera:plugins lists this:

    X:\WINDOWS\SysWOW64\Macromed\Flash\pepflashplayer32_15_0_0_170.dll

  • IDK what's going on, but the pepflashplayer.dll is there. Anyway, thanks!

  • It's the same for me.

    I'm on Windows 8.1 32 bit and I have Opera stable 24.0.1558.61

    I downloaded and installed the latest PPAPI Flash Player: it is installed in
    C:\Windows\System32\Macromed\Flash\pepflashplayer32_15_0_0_170.dll

    but Opera doesn't find it. I tried to uninstall and reinstall the plugin but nothing: Opera sees only the NPAPI version.

  • I see that I'm not the only one with this problem. Stable 24.0.1558.61, Win 7 32bit... I even wrote the comment about this: http://blogs.opera.com/desktop/2014/09/opera-stable-24-0-1558-61-update/#comment-1598704615

  • Is Opera installed for all users? It runs with admin rights?

  • Opera is installed for all users. I tried with and without admin rights, but it doesn't detect at all the pepper flash plugin

  • Opera is installed for all users. I tried with and without admin rights, but it doesn't detect at all the pepper flash plugin

    And what happens if you try with a new clean profile? You can rename your current one or you can make a standalone install.

  • It seems to be a problem with 32-bit versions of Windows... Just saying.

  • It seems to be a problem with 32-bit versions of Windows... Just saying.

    Maybe. Because on my win 7 64 bit it works flawlessly

  • I tried with a new profile: nothing.

    Then I edited the Preferences file to add the lines

    `
       "plugins": {
          "plugins_list": [ {
             "enabled": true,
             "name": "Shockwave Flash",
             "path": "C:\\Windows\\System32\\Macromed\\Flash\\pepflashplayer32_15_0_0_170.dll",
             "version": "15.0.0.170"
          },
    `
    

    but nothing.

    Is there another place where Opera stores its plugin list?

  • Hi @plovec, please follow the below steps:

    1. Download the latest (15.0.0.183) FP for Opera/Chromium based apps - PPAPI for Windows, and install it,

    2. Add two command line switches at the end of the shortcut to the "launcher.exe", as follows:

    
    launcher.exe --ppapi-flash-path="C:\Windows\system32\Macromed\Flash\pepflashplayer32_15_0_0_183.dll" --ppapi-flash-version="15.0.0.183"
    
    

    (adjust the path, accordingly to your Flash plugin installation directory),

    1. Launch the Opera, go to "opera:plugins", click on "Show details" button, disable the Flash plugin with "Type: NPAPI", and enable the Flash plugin with "Type: PPAPI" \m/ 🍺
  • It works! Thank's a lot. 🙂

    The only problem is that I must keep the switches in the shortcut, otherwise Opera loses again the pepper flash player...

  • @l33t4opera, How do I exactly add those command lines, to which file? I'm quite newbie... XD

Locked