:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Default google localization

  • I live in the UK, over Christmas I bought a new macbook in Australia, next day I brought it to Germany and installed Opera 18 from a German IP. Mac region was set to Australia (changed to UK later).

    Opera redirects all searches to google.de in German. Uninstalling and reinstalling doesn't change this.

    How to change the default to google.com without using google cookies?

    With Opera 12 I would edit the default search engine query string, but Googleopera doesn't let you do this any more.

  • Hi, you can try thesolution bySgunhouse.
    1. Close the Opera, go to the Opera user profile directory (you can find the path in O-Menu->About Opera->Paths->Profile),
    2. Open the "Local State" file, and change the "country" and the "country_from_server" values as follows:
    "country": "us",
    "country_from_server": "US",
    or if you would like, you can set them for the UK as follows:
    "country": "gb",
    "country_from_server": "GB",
    3. After that, change the "timestamp" value also (it's important - without this change it will not work), for example:
    from this "timestamp": "1385978822600000000" to this "timestamp": "1485978822600000000",
    4. save the changes, close the file, and reopen the Opera.

  • Zero, have you resolved your problem by now?

  • I have the same issue and try changing the Local State file but every time it flag it as .bad and create a new one ..

  • As I recall, "profile directory" on a Mac is accessed from the context menu of the icon, but not having a Mac myself I can't help further on converting my method to that platform. Local State is readable in a text editor, but not being on that platform I can't say what you need to do to be able to edit it there.

  • Same problem here.

    I'm on os x 10.9.3 and want the searches to default to english. Actually the language in preferences is set to english (us), but that doesn't have any impact on the default searches, which is kinda lame.

    I tried changing the the local state file, by changing country and country from server lines. I also changed the timestamp, but when starting opera the file just goes to .bad state as mentioned above.

    I'd welcome a fix for this.

  • After the latest update of opera next I tried again and it works for me now. Sweet. Google search still forces you onto the country specific search page based on IP. Has nothing to do with opera though, that's just the usual google suckage :)

  • I had the same problem with Google localization in Opera 36. Tried to change country and timestamp but didn't work for me (in my case Opera rewrites the file to the previous country localization). Then I simply removed "locale state" file from Opera profile and restarted the browser. It created a new "locale state" file with the new localization and... finally Google uses it accordingly :).

  • I was about to give up this problem, because changing "Local State" could not solve the problem. (the browser revised the local state back to the original state!). but finally, removing "Local State" worked perfect to me, thanks to the solution from agafitos2003.

    Opera 37.0
    Mac 10.11.4

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.