Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to make Opera continue running when minimized?

  • Hi, I am playing some browser based game on Opera, called Elvenar.
    I notice that every time I minimize Opera, or even just switch to another full-screen window (say a Chrome browser), the Opera browser will stop loading. Like I had a battle still going-on in the Opera window, if I just minimize it, the battle will pause indefinitely until I switch back to Opera.

    I tested with Youtube, seems like it is working as intended, where the videos will continue to play even when minimized, so no issue with youtube playback.

    My Opera version was 78.0.4093.147 or something, and I tried updated it to version 78.0.4093.184 today, it still does the same thing.

    Does it have something to do with the settings? I couldn't find where it says something like "stop refreshing on background" in the settings.

  • @dark3001 Try this: Disable the Put inactive tabs on hold to save memory (the name is not literally that)option in settings.

    if it doesn't work, open opera://discards and uncheck the Auto Discardable for the page you want to keep running.

  • @leocg Nope, doesn't work.
    I've just turned off the "Snooze inactive tabs to save memory" and toggle off the "Auto Discardable".
    Seems like it still pauses my page when minimized.

  • Goto the URL chrome://flags/#calculate-native-win-occlusion, disable the flag, and restart Opera to see if it helps.

  • @burnout426 said in How to make Opera continue running when minimized?:

    chrome://flags/#calculate-native-win-occlusion

    Sorry, I'm a bit confused here, is that a Chrome setting? Does it affect Opera?

  • @dark3001 chrome there is more of a word than a name and it's a prefix/protocol used by all Chromium based browsers. They just replace the original name to avoid confusion.

    So read it as opera://flags/#calculate-native-win-occlusion

    By the way, that's a Chromium flag.

  • @burnout426 Alright, I've tried that, doesn't seem to change anything too.