Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hello! I wanted to test Opera out, but I am having an issue unfortunately.

    "Install Chrome Extensions" does not seem to work for some extensions (currently, trying to install 1Password). The weird thing is, on my Windows machine, I am able to get all these extensions.

    OS: Mac
    Issue: Installing particular chrome extensions result in a "Checking..." box that just doesn't do anything.
    I have already tried some of the typical things (deleting profile, reinstall, etcetera).

    Any clues? Thanks!

  • @horrorsaur In latest release, that extension is no longer needed to install Chrome extensions.

  • @leocg That's good to know! So, I just uninstalled it, wiped my profiles/cache and I'm still getting the same behavior as before. When clicking "Add to Opera", the button text changes into "Checking..." and just stays like that. Any other ideas?

  • @horrorsaur I'm on Windows. When I click on Use in Chrome, the text change to Checking and I see a pop-up with some warning text and a button to add the extension or cancel the operation.

    Don't you see that pop-up?

  • @leocg Nope! Unfortunately, I do not have this behavior on Mac. It is as I described earlier. I have also tried this on my Windows machine and was able to get through installing Chrome extensions.

    This behavior is particular to my Mac, for some reason.

  • Found my issue this morning.

    For some reason, my second monitor was causing the popup to appear off screen. The only reason I came across this was because I went into the workspace mode on Mac and saw that the window was way off.

    Disconnecting my 2nd monitor and proceeding was how I solved my issue.

    Thanks for the help!

  • @horrorsaur said in [Solved] Install Chrome Extension:

    Found my issue this morning.

    For some reason, my second monitor was causing the popup to appear off screen. The only reason I came across this was because I went into the workspace mode on Mac and saw that the window was way off.

    Disconnecting my 2nd monitor and proceeding was how I solved my issue.

    Thanks for the help!

    Oddly enough after a re-image on my work computer and re-installing Extensions I had this same problem this morning, on a Mac with second monitor. Thank you and Duck Duck Go for saving me hours of aggravation.

    thanks