Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Every time I try to play a video on a streaming platform I have that error. It happens on Netflix, Amazon Prime, HBO-GO, Reddit, Instagram... The only place I can play videos is YouTube, which makes it even more confusing.

    Netflix has some instructions that didn't work and I tried these things I found on the web:

    -downloading those updates manually;
    -copy-pasting from the Chrome folder (the whole folder, piece by piece, only the widevine component, every single posibility);
    -going to the site Netflix says and looking for updates from other browsers;
    -uninstalling Opera and reinstalling;
    -deleting the Widevine folder from the Opera folder.

    Nothing worked. I've been trying to fix this for days and I can't find a solution. I'm really done with the double browser and I really don't want to go back to Chrome.

    Picture translation:
    Sorry for the interruption. We have problems to play Netflix. Go to chrome://components look for "Widevine Content Decryption Module" and click on the "search for updates" button.

  • @anasyrma Why the instructions didn't work?

    First thing, is Widevine listed under opera://components?

  • @leocg I don't know why they didn't work. I've done it right as it says and nothing happened, I still have the same issue and the button still has the "not updated" status, even when I just clicked on it.

    Widevine IS listed under opera://components and it says "updated" (it says actualizado really, because it's in Spanish). I just clicked it and now it says "components not updated" (componentes no actualizados) 6ea81c82-1038-427c-8c08-8c960327e49b-image.png

    It didn't work either.

  • @anasyrma It seems fine. Try disabling ad and tracker blockers, as well as extensions. Also try resetting flags and settings.

  • @leocg I am also facing the same issue, although I have disabled adblocker. What could be the other reasons?

  • @barbaralsaunders What about the other 75% of the things you should try?

  • @leocg I have no blockers nor extensions. The problem started when I first installed it after formatting my PC and I haven't even had any time to start using extensions or anything.

  • @anasyrma And Widevine was listed? If it's a new installation, maybe Widevine hasn't been downloaded.

  • @leocg oh I haven't thought that! Do you know how can I solve That problem? I´m not really sure what to download or where to put it and I don't want to improvise.

  • @anasyrma Go to opera://components and update Widevine.

  • @leocg That's the first thing I tried and it doesn't work.

  • Hi @anasyrma, check if "opera://settings/content/protectedContent" is enabled and if not enable it, and see if this helps.

    If it doesn't, try to launch the Opera with the switch as shown below (changing user agent string - add it at the end of the shortcut you use to run it):
    "\path\to\launcher.exe" --user-agent="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.85 Safari/537.36"

    If it still changes nothing, you can check one of the other tips mentioned here.