Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • @voyageur1 Hey, Im not sure if this is a windows issue or an Opera issue, but the problem only occurs with Opera after the latest update to version 75.0.3969.149.
    However this fixed it for me:

    1. Hold down the Windows Key, then press “D“. Repeat these steps to see if it makes the window you are looking for reappear.

    2. Alternately, you can right-click a blank area of the taskbar, then choose “Show the desktop“, then repeat.

    this page might help:
    https://www.technipages.com/bring-off-screen-window-back-onto-screen

  • @jiafoongwee Thx - I will try this, when the problem appears again 🙂

  • Opera opens onto taskbar but does not open on screen.

    I have uninstalled and downloaded 3 times, restarting computer.
    No problems with any of this
    Have removed any remaining residual parts of the program.
    Tried doing all this with anti-virus disable

    I still can not get Opera to show on my monitor.

    Use Windows 10

  • @jiafoongwee It works! You are genius! Thank you 😃

  • Lol, i tried shortcut for windows key+arrows it didnt work, had to create a thread. untill i read this one and tried windows+D, which solved my issue, f... A. Appreciate it man.

  • @bulldwang
    Hey just reposting what is above. Maybe you can try this out.
    I'm not sure if this is a windows issue or an Opera issue, but the problem only occurs with Opera after the latest update to version 75.0.3969.149.
    However this fixed it for me:

    Hold down the Windows Key, then press “D“. Repeat these steps to see if it makes the window you are looking for reappear.

    Alternately, you can right-click a blank area of the taskbar, then choose “Show the desktop“, then repeat.

    this page might help:
    https://www.technipages.com/bring-off-screen-window-back-onto-screen

  • @jiafoongwee

    Twice pressing Windows Key + D fixed this for me, after trying lots of much more technical fixes 😃

    Thanks!

  • Hi, as I see the problem is because opera opens outside the display borders. Thats why some times changing the resolution, or setting for the graphic cards can resolve it - all open windows need to be recalibrated with the new settings. I resolved this problem by changing the display view from landscape to portrait mode. Then the opera showed on the second part of the display, which is invisible when it is on landscape mode.
    I use it on a laptop and also use second display. I have saw that some times opening Opera directly to the second screen, it opens somewhere somewhere on the screen. Not as maximized or last left. I guess it some kind of a problem with the positioning the opera window after closing on a different display?

  • @jiafoongwee That actually worked ... Thanks

  • @jiafoongwee This worked, thank you

    Hitting Win+D Twice worked for me. Didn't even have to reinstall!

  • @jiafoongwee Thank you soooo much, you saved my day/week/life!!

  • @jiafoongwee It worked, you are amazing!

  • @zeej it solved the problem both on my laptop and my home computer. Easy solution for a very annoying problem. Thanks.

  • My opera launches and stays open perfectly fine but, it will not show up on my desktop no matter what. Task manager says its open and when I hover over it in the task bar I can see my browser, But when I click on it or alt+tab it doesn't open.

  • I have the same issue. In my case I have two screens, one of them I use from time to time to watch films (the shared one). Then, if I close opera and after that I stop using this screen (win + P --> Use only PC screen), then the next time I open Opera it is trying to open in a position that is not visible (the old position in the screen that right now I'm not using.

    I can fix it by using some adivces from some fellows here (Win + D), thanks @jiafoongwee a lot.

    It would be nice if this bug can be fixed (please just check if the position exists, otherwise use a default one).

  • @jiafoongwee Thanks a lot. This solved the problem. 🙂 😁

  • I have this issue, seems to have come with one of the last updates as I never had this issue before and I have been using Opera since 2001. I have used multiple monitors for at least 3 years now. But only within the last month or two have I had this issue where some Opera windows just seem to be outside any of my 3 screens.

    I have been trying some of the solutions suggested here, but I also use DisplayFusion to have different backgrounds on each monitor and it has some pretty useful options like moving all windows to the current screen. This worked for 2 of my windows but I have 6 open windows and one of them simply refuses to get back onto any screen even with these solutions where I can move one or all windows to the current screen.

    I hope Opera rolls out a fix for this soon as its very annoying. I do have one solution that works but I just do not like it. That is to use TabHamster a browser plugin that helps manage tabs, it remembers what tabs you have open from day to day and you can save certain tab configurations. I usually have at least 50 tabs open, probably easily more than 100 tabs on a normal day. Then sometimes I finish with a window that has certain tabs regarding some project I was working on with information related to that and save that windows tabs to a tab group in tab hamster, if I plan on continuing on that later.

    But because of this, I have TabHamster remember the tabs that are hidden in the offscreen window, so I can open a new window and use tab hamster to open all the tabs from that window in the new window and then close the old window. Pretty tedious solution, but until Opera fixes this issue, that is the best I can do.

    This issue has gotten me to consider looking for a way to ctrl-tab the same way you can in Opera in some other browser, because this is highly annoying. I use Opera to save time and now I have spent probably an hour or two trying to solve this issue in some efficient way and I still have not found any good solution.

  • I managed to fix the last window, this time I used F11, the full screen button. That made the window that refused to work go into full screen and after making it full screen and go out of full screen I could use my "move window to current screen" shortcut in DisplayFusion.

    Still hope Opera will fix this soon.

  • So 2 days ago I was playing skyrim and went AFK for around 1-2 hours. When I came back the whole screen was buggy and the pc was not reacting, up to the point were i used the power button to put my pc out

    Since then I cant open Opera, always when i open it, the window of opera is open ( and i see p.e. that my tabs are still open, but it stays minimized. Which is kind of frustrating.

    I already tried, reinstalling, restarting, changing my screen settings( i use 2 screens, so i tried to unplug them etc.)

    I tried to add a picture of what i see, even if it is not much maybe somebody can help me?

    THis is all i see from opera:

    asdas.png

  • @nyrion Already tried Win + D and Alt + Space as said in similar topics?