Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

The High CPU/RAM/ETC Usage Topic - Opera GX

  • @leocg Hi! I haven't said anything on this forum in a couple weeks as I've been changing my CPU cooler and such in hopes of keeping my temps under control while trying to fix this. I know you were talking to the other person in this forum, but i have a screenshot of both Opera's task manager and Window's task manager when the problem is occurring. I chose when watching a YouTube video because its the easiest one to grab. The usage/temp problem gets the worst whenever i start/open opera (brings it to 100% CPU usage) and whenever i seem to open or load a new tab it uses quite a bit and makes my temps jump quite a bit.

    unknown.png unknown (3).png

    If you need any other info from me let me know, I'd like to fix this problem asap, also sorry about having my game open in those screenshots, just know it doesn't make a difference to how opera reacts.

  • So, a few days ago I noticed that I was having some stuttering issues with Opera Gx. It started hapening after I updated to the latest version. So I uninstalled Opera Gx and installed the previous version. But the issue was still there. Then I noticed what the problem was. I had two tabs that were using around 300% of CPU (acording to the Hot Tabs Killer) (also, those 2 tabs were a couple of livestreams I was watching on Facebook and Twitch) and I had the CPU Limiter turned on at 33% on Gx Control. Turned off the CPU Limiter and there goes the stuttering issue but CPU Usage went from 33% to around 70 or 80% according to Gx Control. On the Task Manager CPU Usage was around 80 to 100% and also I was reaching max temperature on my CPU. (I'm on a laptop so high temperatures are "normal" when I'm playing but it shouldn't be that high when just browsing).

    And here is the thing. A couple of weeks ago I was able to have 2 1080p videos and a 1080p livestream playing At The Same Time With the CPU Limiter turned ON at 33% and didn't have any issues at all. So I don't know why all of the sudden Opera Gx seems to be using huge amounts of CPU when playing videos and/or livestreams. Also, on a side note, I openeded 2 livestreams at the same time on Chrome and didn't have any issues so it would seem that the problem is only on Opera Gx. Anyone has any suggestion or idea?

    I have an Asus Scar laptop with an Intel Core I7-8750H (6 cores 12 threads) running Windows 10 Home Edition and Opera GX 75.0.3969.255 (64-bit).

  • I am 1 week with this problem with the opera gx using 70-80% of the CPU, this only occurs in lives on the twitch with 1080p resolution 60fps and I can see videos at 4k without problems this only happens with the opera gx has any solution?![alt text](Screenshot_2.png image url) my spec notebook samsung odyssey 2.

  • @kurosora I have a similar issue. But in my case, even watching videos makes my CPU go crazy high. Last night I tried to play a little bit while having only one livestream open and my FPS were horrible. Closed the livestream tab and FPS went back to normal. So yeah, there's definitely something going on with Opera Gx and I can assure that it wasn't there before.

  • When I watch Twitch on my opera GX browser my CPU usage spikes to almost 60%, whereas on Chrome it is really low. I have my settings for hardware acceleration turned on and am still facing this issue. Is anyone else facing this issue?

    Screen Shot 2021-05-10 at 2.38.43 PM.png

    Here are some specs as well:
    Screen Shot 2021-05-10 at 2.43.51 PM.png
    Model Name: MacBook Pro
    Model Identifier: MacBookPro13,3
    Processor Name: Quad-Core Intel Core i7
    Processor Speed: 2.7 GHz
    GPU: AMD Radeon Pro 455, Intel HD Graphics 530

    I never faced this problem with Opera GX until a week ago. It also works fine for me on Youtube, so I am kind of confused. It seems to be just Twitch.

    In trying to troubleshoot the problem i came across this thread which shows that Opera GX users has a similar problem in the past:

    January 2020: https://forums.opera.com/topic/37746/twitch-streams-stutter-in-gx-but-not-normal-opera

    and it seems this problem has persisted even until October/ November 2020 in other threads.

    Anyone has any ideas?

  • @leocg for me it is Twitch that is the major CPU user. Youtube is actually fine for me.

    Screen Shot 2021-05-10 at 2.38.43 PM.png

    you guys can try toggling this setting in Opera GX. Settings > Advanced > Browser > System > Use hardware acceleration when available [toggle it on]

    It will require you to relaunch the browser.

    I tried this but the problem still persists for me. Maybe you guys have better luck with it than me.

  • @cato501 Same . this is a recent thing for me too. i have never had any problems before until a week ago. and it is quite bad - i literally cannot use this browser for Twitch

  • @nandyy I know, I'm using Chrome for watching Twitch or YouTube, otherwise my laptop would just explode for the heat and the high CPU usage. Already tried with Hardware Acceleration on and off and so far nothing. Reinstalled Opera Gx a couple of times and also nothing. And I hace no idea what could be the cause of this problem. Don't know if it would be worth it to file a Bug Report so someone can check it out.

  • @Cato501 - I've explored with several browsers and this seems to be an issue across most Chromium browsers. Brave and Opera GX seems to be the lowest of the two impacted with this bug, but it can still have an issue under high loads. I know this from personal experience.

    In the past few days, I've been playing Dead by Daylight and Final Fantasy XIV on my PC with Twitch in the background. I've thought their updates were the cause of my PC crashing (memory issues, exceptional issues, etc.) and randomly shutting off (once the memory issue was resolved), so I started to monitor the CPU and GPU processes for a few nights. From what I can conclude, it seems to be an issue with the media player and loading onto the website. This is what I've tried doing to resolve the issue and failed:

    • Removed Hardware Acceleration.
      Mitigates somewhat, but either screws up other elements of websites or offsets more resources onto the CPU. This depends on the browser. So, this isn't the solution.

    • Control Panel settings and messed with GPU elements.
      The only thing that helped me were disabling 3D elements and limiting them in NVidia Control Panel, but this went out the window last week. Messing around with settings in the browser didn't seem to make difference.

    • Changed and disabled third-party extensions / ad-blockers.
      Since the issue appeared to be another player issue, I wanted to give a shot of trying third-party extensions and ad-blockers. Firefox didn't seem to work and Opera doesn't have many add-ons to mitigate this problem. Can't mitigate the issue here.

    • Lowered the video quality to 160p.
      It does mitigates, but still has a leakage. This was surely for the sake of seeing what's the core problem and it seems to be what's attached to the media. This alone seems to be causing a majority of the media player's bloat.

    • Rolled back NVidia's Graphics.
      I rolled it back for a few specific versions to see if it removes the problem and thought it resolved. Nope. It caused my PC to shut down while I was gaming and had Twitch on a second monitor. No blue screen, but the culprit was overheated CPU.

    Yeah. This is a lot of troubleshooting I've done over the past few days, but this issue was giving me a lot of hair-pulling and made me stop doing almost everything to resolve it. Unfortunately, there's only one real solution there to resolve the resource hog issue with Twitch, Youtube, and other websites constantly abusing for "higher quality" content.

    The temporary solution, until a more permanent solution comes around, is this:

    • Utilize FrankerFaceZ add-on and disable auto-play on all Twitch videos.

    • Pop out the Twitch chat and keep it in a different monitor.
      You can substitute this with Chatterino chat client.

    • Install the latest version of Streamlink and VLC.

    • Use the Command-line Guide in your CMD.exe window to start watching!

    This helped me cut about 20~40% CPU resource bulkload from the Chromium browsers.

  • @gyrotakashi -

    If you guys don't want to utilize Streamlink, I do have a few other options to try:

    • If you open about://flags/ in Opera GX, these are the options [1] [2] I toggled in the experimental panel that helped reduced some of the stress load on the CPU.
      You may not have to toggle all of these options, but these are what helped me.

    • Nvidia's Control Panel for the Opera GX Browser (same as Opera.exe) was turned down to the lowest settings possible for CPU and GPU settings. #1 #2
      You can alter a few settings from mine for your personal preference, but this works for me.

    • You can increase the memory cache in your computer to compensate for your memory issues, if the issue is related to it. (I did have a memory BSOD related to gaming and twitch running together.)

    This is the result of how my browser is running with a Twitch stream running at 1080p60FPS:
    9a0243bc-3a88-404d-a296-345f9987710b-image.png
    052127fa-bdb7-45d2-98c4-cff04e6f2c09-image.png

    Again, I had 50-70% CPU usage prior to this and had leakage issues on Youtube and Twitch. This solution may not work for you guys, but I figure to throw this out to you guys.

  • This post is deleted!
  • @gyrotakashi Thanks for all the input. I tried changing all those things in about://flags/ and you're right, it does help a little bit. What bugs me is why this started happening all of the sudden? A few weeks ago I had no issue at all. And as far as I can see, there are a few other persons with it as well. My guess is that the only real solutions will come only from Opera. We users can't really do much. Anyways, I'm going to leave a few notes in case anyone finds them a good use.

    Apparently, when you turn on the CPU Limiter On Opera Gx it actually changes the CPU Affinity so it runs on less cores. I have the Limiter turned On at 33% so Opera Gx uses 4 out 12 cores.
    Opera Affinity.jpg

    Here's a screenshot from QuickCPU. Can you guess which 4 cores is Opera Gx using while watching a 1080p60FPS stream?
    Opera Con Twitch.jpg

    And just to compare, here a screenshot while watching a 1080p60FPS stream but on Chrome.
    Chrome con Twitch.jpg

    Quite a difference if you ask me. Also, turning off the limiter on Opera Gx makes the browser use all cores, but then all of them are at above 80% usage which translates into a high CPU Ussage overall plus very high temperatures.

    Again @gyrotakashi solutions about changing a few things in the about://flags/ section helped me so others might try it. But it feels as a workaround until the real issue can be found and fixed.

  • Hello I have such a problem, when I go to a site with video hosting the site loads my processor by more than 100% as it is written in GX ControlScreenshot_1.png

  • Hello,
    i have the same problem, when i watch one twitch stream 1080p and 60fps opera gx use more then 25% of my cpu (i7-7700) when i try this with chrome or edge it is only 5% cpu.
    why did opera take so much cpu? i cant watch a stream and play games at the same time bcs i have only 20-30 fps in game, sometimes opera has peaks from 30%-50% cpu.
    the same problem is on youtube. i dont want to switch my browser but i cant use them so anymore.

  • @shylin Video processing/decoding can use a lot of CPU, specially if hardware acceleration is disabled or not available or if the codec can't be hardware accelerated.

    Check opera://gpu and see if it says that hardware acceleration is being used for the itens in the first section, in special video decode.

  • @leocg but why? Why did opera change that? At the begin and 4weeks ago i didn't had these problems... No hardware change, nothing.

  • @shylin Change what? Opera didn't change anything. Maybe Chromium has changed it. Maybe you have disabled hardware acceleration.

  • @leocg no I didn't change anything, that's why I am so confused.

  • @shylin Confused with what exactly? If opera://gpu says that hardware acceleration is not in use, check in the settings page and make sure it's enabled.

    if it is, go to opera://flags and make sure that opera://flags/#disable-accelerated-video-decode is enabled.
    Also enable opera://flags/#ignore-gpu-blocklist

    After have done that, check again the status in opera://gpu

  • @leocg so i try this, my cpu usage is now by 5-10% but now is my Opera Gx gpu usage at +/- 30%, i will see how it works but i dont know why i need to change something. thx for the help anyways 🙂