:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

JavaScript enabled, but not working in Opera?

  • Until yesterday, my opera 12 was working fine, then suddenly JavaScript is gone! Tried everything that find in the net, uninstalled and installed many times, installed newest java, nothing working. Don't want to update to Opera 23. Firefox is working fine. But, I do need opera to be fixed. Any help please?

  • Some of the 12s were glitchy. Myself have used Opera 11 so far, no such problems encountered. (Generally, a very few very minor glitches in performance/settings rendering - that's all.)

  • Check if you didn't disable javascripy by chance. Press F12 and see if "enable javascript" is checked.

  • If you visit Opera's "Browser JavaScript" website ( http://www.opera.com/docs/browserjs/ ), does it show browser.js status as "enabled", and is the time stamp of the active browser.js file shown there as being June 17,2014?

  • Well, I visited the site:

    http://www.opera.com/docs/browserjs/

    and it shows Current browser.js status: disabled.

    In order to enable it, I went to the page:

    opera:config#Browser%20JavaScript

    and the value was 1. I changed it to 2 and saved. But when I restart the browser, it changed back to 1 again..!! Countless times I tried, no good.

    Now, I dont know what to do. Any help please?

  • Have you installed any new software recently? In special those for privacy and security.

  • No software installed recently at all. I even stopped my anti virus to see if that will fix the problem. Even tried system restore. Uninstalled and installed Opera many times. Tried to fix it in administrative mode as well. Always get the same message:

    Current browser.js status: disabled.

    I tried opera:config#Browser%20JavaScript
    Despite I changed to 2 and save, the value is 1 every time I restart browser.

    Is there a problem in the registry? Would anybody please send me a functioning browser.js, please? Or is there any way to fix this please?

  • First, use Windows file Explorer to look within the same folder as Opera's user operaprefs.ini file is located (find that via: Menu > Help > About Opera -- Paths: Preferences). Is there a browser.js file listed within that same folder; and, if so, what are its "date modified" and file size values?

    Next, assuming the browser.js file is present in the first step, use a text editor like Notepad to look within the user operaprefs.ini file (found in the same folder as the browser.js file). Is the entry for "Browser JavaScript=2" present under the [User Prefs] section of the file or does it instead exist as "Browser JavaScript=1"? If it is set as "1", turn off Opera, use Notepad to change that entry to "Browser JavaScript=2", save the browser.js file in its original place using Notepad, and then close Notepad. Turn Opera back on, use Notepad again to reopen the operaprefs.ini file, and see if the entry remains "Browser JavaScript=2" or whether Opera has forced it back to "1". Report back here.

  • blackbird71, you're a savior! Thank you!!
    Yes, all done well, and now the browser showing 2 and

    http://www.opera.com/docs/browserjs/

    showing enabled.

    However, most importantly, Google does not displaying JavaScript enabled search results. Please see here:

    http://i58.tinypic.com/m92ge8.jpg

    Google was working fine until yesterday!

    I don't want to use other browsers for this, please help me fix this in Opera.

    browser.js
    Date modified: 8/13/2014
    Size 112 kb


    About Opera
    Version information
    Version :12.17
    Build :1863
    Platform :Win32
    System :Windows 7

    Browser identification

    Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.17


    Many thanks in advance....

  • Try masking Opera as Internet Explorer: go to a blank area of the Google page, right click there, select Edit Site Preferences > Network > in the "Browser Identification" box, select "Mask as Internet Explorer" > OK.

  • Fantastic! Absolutely brilliant..!!!
    You're great!
    It works!

    Thank you so so much, blackbird71..!!

  • Thank you so so much, blackbird71..!!

    You're welcome... I'm glad things are working for you.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.