Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Solution to SpellCheck not working, on more than one languages combination, if it is set to "All your languages".

  • Hello, as I previously stated for a long time (roughly from the mid 2020's) the spell check combination on English-Greek doesn't work if it is set to "All your languages".

    It doesn't detect all the mistakes for neither English nor Greek.
    You have to set it every time, to the language you are currently writing, in order for it to work like it should be.

    This happens to all Chromium based browsers.
    I've just read on an article, that around the time that I remember that the problem started, Chrome collaborated with Microsoft to improve spell checking for all Chromium based Browsers.

    I've eventually found a solution, so I will post it here to help anybody who is having the same problem with English-Greek or maybe with another multiple language combination not working, when spellcheck is set to "All your Languages":

    There is an entry on "opera://flags/" called "Use the Windows OS spell checker".
    You just have to disable it and spell check will work like it should after that.

    Unfortunately this flags entry has being removed from other Chromium based browsers I checked(as I found out they used to have it), like Chrome and Edge which I currently have installed on my system in addition with Opera.

    I will also send an issue report to Opera and Chrome, in hopes one of them will look into it and fix it in Chromium's native behavior...

    As always, if anybody from the Forum has a different output, in resolving this issue or how I should handle that knowledge,I would gladly like to hear it.

  • @palx I am using Spanish / English (USA) without problems. I don't have to change anything in settings. I have noticed that I should choose English (any country) if I would like to use the spell check. When I had chose English (without country) I didn't have spell check in English.

  • @diezi I've tried different combinations with English(Any country)/Greek. I've even tried installing different keyboard layouts on Windows 10 Language options, Greek(220), Greek(319) Greek(Polytonic) for example or some different English varieties QWERTZ, AZERTY, DVORAK, since from what I understand the Chromium browsers use Windows 10 own spellcheck system, and the problem must be from there and not from the browser itself. I couldn't achieve any different results….The same problem does not exist on 1 out of 2 other Computers I tested, that use Windows XP for example, with the latest versions of the Chromium browsers.

    As much as I searched on the web for a similar problem, I only found other Greeks complaining on Forums about this, without getting an answer or a possible solution. So it must be a localized Greek/Other language combination glitch.

    The only solution as of now, is setting the browser not to use Windows 10 OS native spell checker.

    The title of this post deliberately uses a generalization for language combinations, in order for it to conveniently show up in general search results, since even with that particulars, I could never be sure, that it does not happen with a different Language combination and someone else with a similar problem might come looking for a solution...

  • @palx It seems to be a problem with Greek language. I had added Greek as spell check and it didn't work with default settings. Then I disabled "Use the Windows OS spell checker" as you mentioned on flags and now there are working all the spells checks.

  • @diezi OK and since I can safely assume, you don't have Greek set as an option on your "Windows Preferred Languages", the problem is not from Windows 10 itself and thus cannot be resolved by tweaking the settings there, but is indeed a problem with how all Chromium browsers handle Greek/Other Languages combination and can only be resolved by the Developers themselves.

  • @diezi and what is also strange, since in the report of the new Spellcheck functionality on Chromium browsers Page Link they state that "If the user has not installed the necessary language pack (or if one is not available), Microsoft Edge will fall back to the prior experience powered by Hunspell."...so you not having Greek installed on your Windows system, should bypass Windows Os spell checker by default, but it doesn't.