Error 535 with Gmail SMTP: Username and password not accepted

  • Dear friends,

    Have been a devout Opera user across many platforms for more than a decade. I particularly like the simplicity of the integrated mail client in the desktop version. However, in the last few days I have encountered a problem which may mean I have to stop using the mail client unless I can find a solution...

    I buy inexpensive web hosting from an Indian company which is notorious for compromised CMS's, dodgy webmasters and lax security. It suits my needs very well, except I have found recently that mail routed through the local SMTP server seldom makes it to the recipient because my outgoing mail server is regularly blacklisted due to other sites hosted on the shared hosting package. Therefore, I have decided to (temporarily*) route outgoing mail through the Gmail SMTP server.

    Enabled POP in Gmail, registered the e-mail account on my personal domain and proved ownership of it. I entered the following credentials for the outgoing mail server in Opera (12.17):

    Server: smtp.gmail.com

    Username: me@my-domain.tld

    Password: *************

    TLS enabled (no SSL option in Opera 12.17)

    Authentication: Auto (Auth Login)

    Port: 587

    Although it works perfectly on my iPhone (albeit over port 993), when I try to send e-mails in Opera I receive an error message:

    The server responded: 535-5.7.8 Username and Password not accepted. Learn more at

    535 5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257 [....] - gsmtp

    Followed all the steps on this page, including the unlock captcha, choosing a secure password and enabling less secure applications, but still nothing. Found an Opera user encountering a similar (530, not 535 error) here: https://productforums.google.com/forum/#!topic/apps/o8IuVu-ta9o - the solution was to activate SSL and use port 465.

    Opera 12.17 doesn't seem to have an SSL option. Is there something I'm missing?

    Any suggestions appreciated. Thank you in advance!

    * Ultimately I want to stop routing my outgoing mail through Google and set up an OpenSRS (or similar 3rd party hosted mail solution with a good reputation). I cannot afford to do this at the moment!

  • Did a bit of further snooping and apparently Gmail does not support TLS for POP3 but apparently they do for SMTP: https://productforums.google.com/forum/#!topic/gmail/UOlP6LSxg68 -- is this up-to-date?

    Is there a way of using SSL over SMTP with Opera Mail?

    Thanks!

  • Try changing smtp port to 465.

  • Thanks for your suggestion. Sadly doesn't work. Could this be because Opera 12.17 has a TLS option, but no SSL option for mail servers?

  • Have you tried retyping your username and password?

  • Thank you - yes I did, many times.

    I finally found the winning configuration:

    Server: smtp.gmail.com

    Username: mygmailaddress@gmail.com

    Password: *************

    TLS enabled

    Authentication: AUTH PLAIN

    Port: 587

    I had to do the Unlock Captcha after entering these settings. I had already done this, but for the benefit of anyone trying to do this in the future, remember you need to set up your personal e-mail as a "send mail as" account in Gmail settings. It does not need to be an alias. Set it as the default "send mail as" account if you want to send mail as your own domain account - not sure whether this undermined my original objective of not being blacklisted if Gmail is still sending through my personal SMTP server.

    I don't know if it made a difference but I also enabled IMAP in Gmail.

    Thanks for your help!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.