Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • My Javascript bookmarklets stopped working after I updated Opera to the latest version.

    Version of Android: 62.1.3146.57513

    Phone model and manufacturer: Multiple including Samsung Note 4 and S6, LG G4, Honor 8 and Motorola E2

    Your version of Opera for Android: Multiple including Android 6., 7 and 10

    If the problem is with a page, a link to it: NA

    If ad-blocker is enabled or not: Issue occurs with it on and with it off

    If data savings is enabled or not: Issue occurs with it on and with it off

    A screen-shot of the problem if it's related to something not showing as should: N/A

    A description of the problem, including as much as information as possible: Javascript bookmarks do not work. They did in previous Opera versions up to and including version v. 61.2.3076.56749. They also work in Android Chrome 88.0.4324.181.

    Steps to (try to) reproduce the issue:
    Create a new bookmark. Enter Tweet it in the Name field and the following code in the Address field:

    javascript:location.href='http://twitter.com/intent/tweet/?text='+encodeURIComponent(document.title)+' &url='+encodeURIComponent(location.href);
    

    (This will create a bookmarklet that share's the current page's title and URL on Twitter).

    Open any web page in Opera. Go to bookmarks and select the Tweet it bookmarklet.

    Expected behavior and actual one:
    Expected: Twitter compose Tweet dialog opens with the current page's title and URI already entered.
    Actual: Nothing happens at all.

    I hope this issue can be resolved. Bookmarklets are an important part of my daily workflow. I use them for sharing to social media and updating sites I manage.

  • i experience the same problem since version 62.

  • @yeswap same here, thanks for the accurate report

  • Same exact problem using the EmailThis bookmarklet on Opera for Android on Samsung Galaxy S10 Plus. Just stopped working. Tried re-creating the bookmarklet, but same exact result. I type "Email..." in the address bar, I see my bookmarklet with the title "Email This" that shows the address of "javascript...". I tap it, and nothing happens at all. Just started 3 or 4 weeks ago.

  • We have removed JavaScript URL support due to security reason. We want to provide product with best possible security.
    Regards
    Opera Team

  • @neetesha That's what I guessed, but it's still very annoying when features are removed because of "security", especially when it's something that distinguished your product from the competition. Is there any chance that bookmarklets can be white-listed or opted-in from the settings, instead of just disabling them outright?

  • @dargor17
    Sorry to say but no, its not possible. I hope you understand.
    Regards
    Opera Team