:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Opera 25 - Abnormally large minimize, maximize, close controls.

  • Opera 25.0.1597.0
    OS - Windows X P Pro 32bit SP3

    The minimize, maximize and close buttons on Opera 25 are considerably bigger than on any other program on my pc. Is there a way to adjust the size of those controls in Opera 25?

    I've posted a screen-shot on imgur.com comparing the Opera 25 vs. Opera 12 controls.

    http://imgur.com/GQCdgla

  • You actually have the old Windows 9x/2K style enabled? Unfortunately recent versions of Opera (since the change to Chromium) no longer support that style - not that they support XP very well anyway, my desktop is set to use olive green but Opera is always blue. :(

    Edit: they really need to change that smiley. Writing X P together shouldn't do that ...

  • Yes I do have Windows set to that visual style.

    Actual Chrome does NOT have the ridiculous big buttons btw. They ARE skinned but they are only slightly large than the other min/max/close buttons for everything else.

    http://imgur.com/oilmBmy

  • While Opera uses Chromium as the rendering engine, the UI is totally their own. That's why Opera can outperform Chrome on speed tests - their interface is simpler and allows more processor resources to be devoted to rendering.

  • This is due to HiDPI support now being permanently enabled in Opera Developer.
    I have the same problem, and all websites look zoomed in about 25% too!
    Setting the default zoom to 75% does fix that, but doesn't correct the UI elements' size.
    I have filed it as a bug.
    A workaround is to run Opera with the switch "--alt-high-dpi-setting=96", but this is not ideal.
    :)

  • So, you're expecting things to work properly on an OS that has been dead for a few months now?

  • This is due to HiDPI support now being permanently enabled in Opera Developer.
    I have the same problem, and all websites look zoomed in about 25% too!
    Setting the default zoom to 75% does fix that, but doesn't correct the UI elements' size.
    I have filed it as a bug.
    A workaround is to run Opera with the switch "--alt-high-dpi-setting=96", but this is not ideal.

    Dave thank you very much for having actual information and a useful workaround for the big text (I had been wondering about that too), I'll test it out when I get to work today.

  • So, you're expecting things to work properly on an OS that has been dead for a few months now?

    Until Opera officially declare that Windows X P is no longer supported by their browser, yes I am!
    :)

  • So that startup switch works nicely to put the text on websites back to the proper size.

    Hopefully they come up with a fix for the stupidly big min/max/close buttons in a future version.

  • Did the switch not fix the UI buttons' size as well?
    It does on my system.
    :)

  • Did the switch not fix the UI buttons' size as well?
    It does on my system.

    Upon closer inspection it did fix that issue as well. Thanks again!

  • Good to hear!
    Unfortunately I don't consider this to be a permanent fix, as it doesn't work if the browser is run by any means other than by a shortcut, e.g. by clicking on a link in an e-mail. This can be corrected by registry editing, but it will probably be over-written if there is a major update.
    :)

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.