Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]opera hangs after about one minute even without web sites

  • I have used Opera for over twenty years. In the last two days it started freezing. I updated, reloaded, removed everything, installed fresh, changed profiles, tried every setting I could think of, killed AV and Malwarebytes. No effect. I can open it, do nothing and it will hang. It seems to spawn way too many processes, but I admit to not looking when it was working. It's as if Microsoft decided I can't use Opera anymore.

    I'm attaching two about screens. I noticed the about screen changed right after I copied the first one, saying the update check failed. I'm also including my Microsoft info and a couple of task manager captures.

    windows.JPG procs.JPG procs after end task.JPG opera about.JPG opera about 2.JPG

  • Can someone reply and let me know how to completely (registry, folders, etc.) remove an Opera installation so I can try loading again?

  • @dihlen Did you try installing Opera in C:/Program Files?

  • @dihlen did you try delteing opera with the help of the system control page? There it should delete everything that belongs to opera. But after that better check if all folders are really deleted and then a new isntallation should be possible

  • @dihlen did you use the system control manager for deleting opera from your computer? Usually that deletes everything.
    But you can also look for "opera" in the search bar and deinstall all folders that might still be there manually.

  • @leocg I reinstalled and did clean installs, I didn't notice it asking me to change the installation location. Did I just miss it or is their a special install?

  • @lukas425 I went through control manager, but I haven't searched the entire file system for Opera directories.

  • @leocg Incredible. I deleted the last install through control panel. I told it to delete all my data (again). I had it install for all users and put it in "Program Files."

    Same behavior, freezes after one minute. To the best of my knowledge there were no PC changes in the last few days.

  • @leocg I take it back. It appears that installing for all users and in Program Files" has resolved the issue. I still wish I knew what caused it.

    Thanks for the hint.

  • This post is deleted!
  • @dihlen so you just had to install it for all users and in Program Files?

    Sounds interesting and I can also not tell what the problem was but I guess its good to know in case anyone else faces the same issue 😃