Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Address/Search bar doesn't work, won't let me enter, grays out text, etc

  • This morning I opened up Opera and was going to search something and it was working fine at first but then I opened another tab and tried to search another thing and the search box changed size a bit and my text turned gray and I was unable to press enter to search at all. I've tried everything besides reinstalling opera, I don't know what to do opera is broken for me941619fc-faeb-42f3-b4cb-11be47721ae0-image.png This is what it looks like when I try to search, reopening opera allows me to search once and then when I try again it grays out my text. Please help me I don't know how to fix this aside from reinstalling opera and redoing all of my settings and bookmarks which would suck or just switching back to chrome

  • I have the same problem.

    It's completely random. Sometimes I get some results (either from search or from history) while I type, but even after few characters it greys out. Even if I delete it and start typing again it stays like that. And it not only affects search - I'm trying to enter whole URL and hitting enter won't do anything.
    Additionally I noticed that it starts to work when I enter Private mode.
    I tried to disable ALL extensions but it didn't help. I'm also not keen to reset it or reinstall and starting from scratch.

    And I have to say it's a big thing cause it makes my Opera unusable. I can only go to some sites through history or bookmarks. If I have to type it works after I open 7 or even 10 new tabs.

  • @Swollward What version of Opera?

  • Same over here. Opera version 72.0.3815.207.

    Opening a new tab and typing anything (urls, search terms, search shortcuts) in the address bar does nothing beyond displaying the greyed-out text. My workaround has been to launch a webpage via a bookmark, and the address bar then becomes functional. Or to shift focus away from the tab (by clicking on another application window or browser tab) and then return to it.

  • I have the same problem.

    It started couple days ago and only way to use search is to "rewrite" opened windows URL. It is really annoying to use Opera browser atm.

  • Same here, I have had 72.0.3815.186 - just (in this moment, when I was checking the version) made an update and for now it looks, like it's fixed. Maybe try it also.

    But it is only after 1 minute of testing.

  • I first noticed it on 72.0.3815.182 (l may not remember this version correctly), then it got updated yesterday to 72.0.3815.200 and today to 72.0.3815.207 - bug still exists.

    Windows 10 Pro 2004
    19041.572 compilation

  • Im waiting on accepting my post by moderator, where I wrote that after update it works. It didn't - newest build, still the same problem. It is also impossible to go to site, when you put adress in search tab. It is just not working at all. You press enter - nothing happens.

  • URL search doesn't work
    It use to be: new window > search phrase > Enter and you would get results from default search engine. Now it doesn't do anything.
    Even if I use keyword from other search engine, I don't get any results.
    It's same behavior on two different computers.

  • For the time being click on the reload circular arrow in the upper left, then click in the address/search space.

  • Update: It took longer than usual for the firewall pop-up to arrive after the last update. This time I checked both permissions. Now the graying out search problem has stopped. Related?

  • I fixed it by recovering opera and when updating it again. After this opera's search is working. To do that you need to go to Menu>Update&Recovery..
    I hope it will fix it for you too.

  • I did nothing and now it occurs much less often. 1 in 10 attempts greys out. I can confirm that focusing in/out and reloading the new tab helps, but the problem is still there.

  • I have same problem on two pc's. It first occurred yesterday on both Operas of latest version: star typing address - click Enter - nothing. New tab - type - Enter - goes ok. Every 1 of 10 or kinda.

  • Same problem. I can't go without Opera it, I will see if I start using the GX for now.


    EDIT: Now that I see you have an update. Apparently, now it's back up and running. (72.0.3815.207)

  • Interesting, similar problem here today - dev stream 74.0.3862.0. Alt-tabbing to another app and back to Opera seems help.

  • @leocg the same thing for me. Opera version 72.0.3815.207

  • @Swollward if you see this problem, just press F5 button. After that you may enter text as usual. That is a workaround. I hope, that Opera will fix it soon.

  • Yeah... Even with 72.0.3815.207, the bug came back.

  • Same problem for me, started happpening to me yesterday during the evening! What's bug is causing this I wonder....