Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Address/Search bar doesn't work, won't let me enter, grays out text, etc

  • Same issue for me since this morning. Thought it was a bad update or something, updated to latest still the same.

    Especially interesting that known URLs seem to work, only when we venture into "unknown" territory it does not work any more, and also no google suggestions show up (which maybe is related?).

  • I have the same issue, although there is a workaround for me.

    It works at least for me wenn u take the automatic focus of the searchbar when opening a new tab.
    For me atleast it even works when anywhere else on the screen and then back into the searchbar.

    It makes Opera useable again but still extremly annoying.

  • Version : 72.0.3815.207

    Same thing here. Search bar grays out after a very short while once I've typed anything in it. It also seems to only happens when I'm on speed dial ?

    Switching to another tab seems to fix it... until it grays out again.

  • Same here. Open new tab, F5 and then it works. But it is terribly slowing the process.

  • Same problem with 72.0.3815.207.

    Open tab, writing on omnibox, is grayed out text and there's no dropdown with history or suggestions... Pressing enter does nothing. It works one in ~20 attempts by opening a new tab.

    At least the F5 hack works, but this needs to be fixed asap...

  • @namero999 Good workaround at least ... better than copy-pasting stuff from some notepad or something 🙂

  • I have also experienced this problem since 72.0.3815.207

    As a temporary fix, I have rolled back to 72.0.3815.186/ from 29-oct
    To do so, download your preferred version from the Opera FTP, and disable auto-update for the time being (see here).

    Hope this helps

  • Same in beta version updated today (73.0.3856.31).

  • I checked it in latest 72.0.3815.207 Portable (because I'm still on 69 version and disabled updates to avoid 'surprises' from Opera) and I don't have the described issue. I'm on Win 8.1, maybe Win 10 issue only.

  • I have the same problem on 72.0.3815.207

    As a temporary fix, I have rolled back my Opera version to 71.0.3770.284 (20-Oct-2020).
    You can download a previous version from the Opera FTP. Don't forget to turn off auto-update (rename Opera_AutoUpdate.exe in your installation folder).

    Let's hope there is an official fix soon, but for now this is a good workaround.

    Hope this helps!

  • Same problem here with the 72.0.3815.207 version on w10.

  • I also noticed that pressing TAB 4 times when on the omnibox, makes it work again. You can clearly see that the cursor stays on the omnibox for the first 2 presses, then goes somewhere on the left of the omnibox, and then comes back on the omnibox and it works... So the bug might be related to some focus handler going havoc or something...

  • Hi

    I have same problem on win10. Just updated from 72.0.3815.186 to 72.0.3815.207 which didn't help.
    Searchbox is not working when opening new speed dial, but it does on existing tab.
    When opening new tab and entering some search term, nothing happens.

    Workaround is after opening new tab, pressing tab (on keyboard), then shift tab so that focus goes off the search box and goes back. that ''fixes it''. You have to do it on empty searchbox, if you do it when something is already typed in, it will try to open page like http://opera%20searchbox%20not%20working/

    Another thing that i noticed, when opening new speed dial tab, while opera is loading that new speed tab (there is x sign left of searcbox - stop loading tab icon), searchbox works, but as soon speed dial tab is loaded it stops working (x icon changes to round arrow - refresh icon).
    Also, searchbox works fine when I'm not connected to internet.
    At last, not sure if its connected, but I noticed that if I close Opera, it doesn closes completely. Opera window gets closed, but it's still open in task manager. So, if I want to reopen Opera, I have to close processes which is extremely annoying as much as searcbox problem.

    This is some wierd bug
    If it doesnt get solved by the end of the next week, im switching browsers.

  • 533b3da2-2a86-48d6-ae56-c26a640923b6-image.png

    When typing into the search bar on a new tab the text is grayed out and no results appear underneath.

    This can currently be fixed by clicking off when the text box is empty and clicking back on again but this is a bit of an annoying bug.


  • You can click off and on again on the search bar as a temporary fix. Hoping the devs see this soon as it's quite annoying!

  • @namero999 heck it seems sufficient to just unfocus the field (by clicking outside) and focusing it again. Also note how the font looks different before and after (before is really thin)? What a weird bug.

  • I am having the same problem with two differents computers. Windows 10 x32 and x64 with last Opera version. F5 key works to reuse the browser. I can't use the tip given by @namero999 pressing <TAB> key.

  • I open the empty tab, I input the URL, I press enter - nothing happens.
    In case I use some bookmark to load any website, and then enter the URL, it works just fine. It all started 2 days ago.
    Opera 72.0.3815.207 Windows 10 x64

    The issue is pretty similar to but killing GPU process doesn't help.

  • Yep seems like the same issue.