Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Update disables the system

  • On Windows7 Pro, Opera 71.0.3770.284 and few consecutive earlier versions since late August 2020 Opera Autoupdate almost crashes the system by excessive consumption of resources once it starts. All CPU cores are at max, memory at max, intense disk usage and dominant network usage. Detected that multiple opera_autoupdate.exe and single Opera_Stable_#### (version number) processes are the ones gobbling the resources by using the only somewhat-working process on Windows when the problem arises- the task manager. Even it, after ctrl-alt-delete, takes several minutes to appear but afterwards is functional. All other applications behave as if dead/crashed. Once update is done (typically about 30 minutes) everything else returns to normal, including Opera browser itself, the Windows system and all other applications. Just as nothing have happened. Problem that is particularly irritating is that there is no announcement or option to request Opera to ask user if it is OK to start update. Hence some of my interaction-critical work was unacceptably killed in the middle of it and this is very bad for any user doing any serious work. I reported this as Opera bug but no response there. Any suggestions?

  • In Opera, goto the URL opera://about and take note of the install path. Then, close Opera.

    Uninstall Opera (don't choose to delete your data when uninstalling). After uninstalling, if the install folder is still there, delete it.

    Delete all files and folders in "C:\windows\temp".

    Delete all files and folders in "C:\Users\yourusername\AppData\Local\temp"

    (to get rid of old, Opera update and installer stuff).

    Open the Windows Task Scheduler and delete any Opera tasks that are in there.

    Then, download the Opera installer from https://www.opera.com/download, launch the installer, click "options", pay attention to the options and adjust them like you want, and install.

    Then, if still have the problem and you want, you can add the OPERA_AUTOUPDATE_DISABLED environment variable (value doesn't matter) to your system to stop automatic updates.

    Further, after each time you update Opera yourself, you can remove the autoupdate tasks from the Windows Task Scheduler and delete opera_autoupdate.exe in the latest version folder in Opera's install folder.

    You can also modify Opera's shortcut to pass --disable-update to Opera's launcher.exe.

    You can also add 127.0.0.1 autoupdate.geo.opera.com to your HOSTS file if you want to block the checking for updates.

  • @dusanmal
    Have you any 3rd-party security tool (antivirus suite or similar) installed? It could be possible that some such near-system software component interferes with Opera installation.

    In windows event log, do you have some kind of errors at updating time? In old, pre-SSD times, HDD-s with bad sectors or bad connectors could cause such behavior. Well, this should be noticeable in other applications too.

    On my PC-s (2xW7, W10) Opera updates don't cause any noticeable system stress; so haven't I heard about such kind of problems from other Opera users - thereby I think that this problem is likely related to your PC (soft- or hardware) configuration.

Log in to reply